Topic: Image link does not work

I have no problem to work with Google Picasa links and images, but Shutterfly link is NOT working.  hmm

This is a part of XML >>

<photo imageurl="http://im1.shutterfly.com/procsrserv/47a1da04b3127cce98548ac7932500000030102AbMWjds3btD/cwvDm9asA3Lw9atmAbl5etGTDg/cC/f%3D0/ps%3D0/r%3D0/rx%3D150/ry%3D200/" linkurl="" showFlipButton="false"><title></title><description></description></photo>

What is wrong with the link? I can open http://im1.shutterfly.com/procsrserv/47 … /ry%3D200/ in any browser without problems.

Please advice.
Thank you.

Last edited by mtyson (2011-04-26 13:00:49)

Re: Image link does not work

Are you sure Shutterfly allows you to pull images from their site? Beyond that TiltViewer maybe expecting a file with a file extension such as .jpg.

Mike Richards
SimpleViewer Support Team.

Re: Image link does not work

Mike Richards wrote:

Are you sure Shutterfly allows you to pull images from their site? Beyond that TiltViewer maybe expecting a file with a file extension such as .jpg.

Mike, I have no problem to use Shutterfly links and images with some other viewers, so I am pretty sure that Shutterfly does not block anything.  neutral

Regarding .jpg extension - that is not an issue as well, as even modifying a link from "http://im1.shutterfly.com/procsrserv/47 … /ry%3D200/" to "http://im1.shutterfly.com/procsrserv/47 … 00/img.jpg" by adding "img.jpg" at the end does not help and new link http://im1.shutterfly.com/procsrserv/47 … 00/img.jpg works with all browsers nicely.

Can you please do some testing and/or debugging on your side?  roll
Thank you, Mike!

Re: Image link does not work

To ensure everything is okay regarding Shutturfly response I checked HTTP headers and I got correct information >>

Resolving im1.shutterfly.com... 64.74.142.151
Connecting to im1.shutterfly.com|64.74.142.151|:80... connected.
HTTP request sent, awaiting response...
  HTTP/1.0 200 OK
  Server: Apache-Coyote/1.1
  Expires: Wed, 25 Apr 2012 14:19:16 GMT
  Content-Type: image/jpeg
  Content-Length: 11101
  Date: Tue, 26 Apr 2011 14:19:16 GMT
  Via: 1.0 im1.shutterfly.com:3128 (squid/2.6.STABLE12)
  Connection: keep-alive
Length: 11101 (11K) [image/jpeg]
Remote file exists.

Last edited by mtyson (2011-04-26 14:30:06)

Re: Image link does not work

It looks like ShutterFly do not allow loading images cross-domain into Flash.

In order for Flash to load images cross-domain, there needs to be a cross-domain policy file in place at the image source web server.

You can contact ShutterFly tech support about this, or use a different source for your images, or use a web proxy.

Felix Turner
SimpleViewer Support Team.

Re: Image link does not work

Felix wrote:

It looks like ShutterFly do not allow loading images cross-domain into Flash.

In order for Flash to load images cross-domain, there needs to be a cross-domain policy file in place at the image source web server.

You can contact ShutterFly tech support about this, or use a different source for your images, or use a web proxy.

Yup, that's it! Shutterfly wants each person seeing pictures from their website to be their customer.  yikes

I've coded a simple webproxy, which was the only solution, but it is terrible slow now.

It would help a lot, if TiltViewer Pro would come with option to download "thumbs" from separate links and then silently download/preload large images in the background, replacing thumbs after that. Mike & Felix - do you plan to implement such feature?

Because it is slow, it has also very confusing behavior when user click arrow to load next images. If images from previous page would gray out, then it would be much nicer, as now you cannot really tell if page is still loading or all images you see are already from new page. I would like to see "gray out" feature in next release as well.

Last feature I'm missing is automatic resizing (zoom in/out). When I resize window vertically, gallery is adjusting nicely. If I resize window horizontally, it does not adjust properly. At least with Internet Explorer it is an issue; don't know about other browsers...

So question for developers: Can you do something with above mentioned issues..?
It is great product, but it can be always better  big_smile

Thank you!