Topic: Transparent Background not displaying in Safari

Hi there,

I have been trying to get safari to display a transparent background however to no avail sad  it works in all the other major browsers, I am using simpleviewer v2.1.3

Im using the code generated by SV builder and embedding into my DW file it is as follows:

  <div id="mainContent"><!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "transparent", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Any help or advice fixing this problem would be greatly appreciated  smile

Thanks

Daniel

Re: Transparent Background not displaying in Safari

You can test whether the transparency is working or not by giving the 'sv-container' <div> a background color via CSS:

<div id="sv-container" style="background-color: #acc2e3;"></div>

... which should be displayed when the background color Embed Code Parameter is set to 'transparent'.
It works fine in Safari 5.0.5 on my PC.
(In the code you posted, you have not closed your 'mainContent' <div>.)

If you continue to experience difficulties, please post a URL to the gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: Transparent Background not displaying in Safari

Hi Stephen,

Thanks for getting back to me, I tried your css suggestion and it turned my background a light blue, so then I deleted the light blue hex and uploaded but still got the dark grey background sad  the url is

http://www.keeryphoto.com/loactionport/NewLocation.html

Im not so au faux with coding so it could be I have left something out?

Daniel

Re: Transparent Background not displaying in Safari

Your gallery's background is transparent in Safari 5.0.5 on my PC.
Try clearing your browser's cache before reloading the gallery.

Steven Speirs
SimpleViewer Support Team.

Re: Transparent Background not displaying in Safari

Hi Steven,

Thats great, however I have updated my safari to 5.05 and reset everything however Im still getting the grey background on my computer could this be down to some safari settings? or perhaps a conflict between my flash player and safari?

Daniel

Re: Transparent Background not displaying in Safari

I also tested on a colleagues computer there and they are also getting the grey box sad

Re: Transparent Background not displaying in Safari

You can check which version of Adobe Flash Player you have by visiting this page in your browser: http://kb2.adobe.com/cps/155/tn_15507.html
I have WIN 10,2,159,1 installed in Safari.

However, the gallery's background should also be transparent if Adobe Flash Player is not installed (or disabled) and the mobile player is used to display your images using HTML.
If I temporarily disable plugins, your gallery's background is still transparent in Safari on my PC (and iPod Touch).

Your code looks OK and your gallery's background is transparent in Safari on both my PC (with and without Flash) and on my iPod Touch.

You could try setting the 'wmode' parameter to 'transparent' directly in the embedding code to see if this makes a difference:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var params={};
params.wmode="transparent";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "transparent", true, null, params);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: Transparent Background not displaying in Safari

I have WIN 10,0,2,54 would this be causing the conflict, is this an older version of flash player? I have also added that new code but it still displayed the grey box, im sorry to be such a pain, I know that youve tried to help me and im grateful for it smile

Daniel

Re: Transparent Background not displaying in Safari

just looking at my code and everything is saying transparent so i think that it must be a problem with apple/safari not picking the code up right?

Re: Transparent Background not displaying in Safari

Two things to try:
(1) Upgrade your Flash Player to the most recent version (10,2,159,1).
Is the gallery background transparent now?
(2) Try using the mobile player instead of Flash.
Either disable plugins temporarily (Tools -> Preferences -> Security -> Web Content) or force the mobile player in your embedding code:

simpleviewer.load("sv-container", "100%", "100%", "transparent", false);

Is the gallery background transparent now?
(Be sure to clear your browser's cache before trying each suggestion.)

Steven Speirs
SimpleViewer Support Team.