Topic: Gallery XML Not Found (iPhone only)

Hi. I am sure you have answered this somewhere else, but I cannot find it. I am unable to view my gallery on iPhone only. I'm certain I've missed something in the code, but I cannot figure it out. Your help would be appreciated!

Here is the website: http://irenerosenyc.com/gallery.html

And here is the code:

<!--START SIMPLEVIEWER EMBED -->
                          
              <script type="text/javascript" src="http://www.irenerosenyc.com/gallery/svcore/js/simpleviewer.js"></script>
              <script type="text/javascript">
    var flashvars = {};
flashvars.baseURL = "http://www.irenerosenyc.com/gallery/";
flashvars.galleryURL="http://www.irenerosenyc.com/gallery/gallery.xml";
    simpleviewer.ready(function () {
        simpleviewer.load('sv-container', '800', '750', 'transparent', true, flashvars);
    });
              </script>
                        </p>
            <div id="sv-container"></div>
    <!--END SIMPLEVIEWER EMBED -->


Thanks so much, in advance, for whatever help you can give me!

Re: Gallery XML Not Found (iPhone only)

Go to http://www.irenerosenyc.com/gallery.html and you should see your gallery.
irenerosenyc.com and www.irenerosenyc.com are considered different domains.
Please see here for details: http://simpleviewer.net/simpleviewer/su … trouble_11
Try setting a relative rather than absolute baseURL.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML Not Found (iPhone only)

Thank you so much! I can see the difference you're talking about. I'll look through the documentation you referenced to address the issue. I appreciate the quick response!

Re: Gallery XML Not Found (iPhone only)

Thank you so much- I appreciate the quick response! I can see the difference you're talking about, and I'm able to manipulate the base URL to make the gallery work in using either domain. But I still can't figure out how to get both domains to view the images.

I have tried installing the crossdomain.xml (as suggested in your link) in both the root folder on the server, and in the images folder on the server, and neither of those seem to do the trick. I have also tried making the baseURL "/gallery/" instead of using the absolute URL, but that hasn't worked. I'm sure I'm missing something simple- but I'm not that familiar with JS so I'm not finding it.

For now, I'm satisfied with having it accessible via only the "www" domain, but I would love to be able to have it accessible both ways via the iPhone, if possible. Thanks again!

Re: Gallery XML Not Found (iPhone only)

Try setting the baseURL to "gallery/" and remove the galleryURL setting.

Felix Turner
SimpleViewer Support Team.

Re: Gallery XML Not Found (iPhone only)

how can i change the gallery setting?

Re: Gallery XML Not Found (iPhone only)

That works perfectly - thank you! (I had added the galleryURL function because the gallery was initially not loading in IE, but it seems to be working fine now.)

Thanks again for your quick responses!

Re: Gallery XML Not Found (iPhone only)

Looks like you've got it figured out.
Your irenerosenyc.com gallery now displays OK on my iPod Touch.

Steven Speirs
SimpleViewer Support Team.