Topic: Gallery seems to "stick"

Hi,

I just created a new gallery. It works fine on an older version of Firefox, but "sticks" on Firefox 4.01 (mac). I checked it on Safari (mac) and it doesn't stick there, although the captions don't show up.

Would you have time to look at this for me? Thank you very much!
Camille

http://www.unmalumni.com/brick-brigade.html

Re: Gallery seems to "stick"

The first thing to try is to upgrade your gallery to the latest version of SimpleViewer Pro (v2.1.3).
Upgrades are free within the same major version number so you can download the latest version from the link in your purchase email.
If you cannot find the email or your link has expired, please fill in this form to receive a new link.
Once you have the latest version, replace the 'svcore' folder in your gallery with the 'svcore' folder from the SimpleViewer Pro download package ('simpleviewer_pro_213/web/svcore/').
Also, update your embedding code with the new style found here.

Inconsistencies when viewing a web page in different browsers can often be attributed to HTML errors.
You can check your page using the W3C Markup validation Service and then fix any errors found.

I just created a test gallery (v2.1.3 Pro) and used your gallery's XML settings and my gallery runs OK so it is not an issue with conflicting settings.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery seems to "stick"

Thank you for getting back to me so quickly! I will try this tonight.

Re: Gallery seems to "stick"

It seems to be a problem with Firefox 4.1.

I made all the changes you recommended last night. When I open the gallery in Firefox 4.10 on the mac, it sticks and doesn't navigate smoothly.

I reinstalled Firefox 3.6.17, and the gallery runs perfectly.

Re: Gallery seems to "stick"

Your gallery no longer 'sticks' in Firefox 4.0.1 on my PC.
(It did yesterday when I checked it.)

Steven Speirs
SimpleViewer Support Team.

Re: Gallery seems to "stick"

I'm not sure what to say then. I am definitely having some sort on conflict on the Mac with Firefox .

Re: Gallery seems to "stick"

Your page still has several HTML errors which should be fixed.
Does your gallery 'stick' when you view it locally on your computer or just when viewing the uploaded version online?

Steven Speirs
SimpleViewer Support Team.

Re: Gallery seems to "stick"

Its only in Firefox 4.01 that it doesn't run correctly. It works fine locally and on other platforms. I installed the previous version of Firefox to test it, and it works fine in Firefox 3.6. It also works fine in Safari. I haven't tested it on a PC. I did use the W3C Validation site to correct the html errors.

Re: Gallery seems to "stick"

Usually if the gallery works in several browsers and not in one it has to do with an error in your page. You still have some errors such as using and ampersand (&) instead of &

http://validator.w3.org/check?verbose=1 … igade.html

Mike Richards
SimpleViewer Support Team.

Re: Gallery seems to "stick"

Sorry, I was validating the wrong page.

The errors are corrected in the page with the gallery. I wish I could show you what the gallery is doing, but it is still running very strange in Firefox 4.01. It seems that each image takes a long time to load, and the gallery stalls when I change between images, even though I have preload set to "ALL".

Re: Gallery seems to "stick"

Your site seems to be working fine in Firefox 4 for Windows, could be a Mac/Flash issue. What version of flash are you using with Firefox 4 on your Mac? If it is less then the current version, 10.3.181.14, try updating to the latest version.

http://kb2.adobe.com/cps/155/tn_15507.html

Mike Richards
SimpleViewer Support Team.

Re: Gallery seems to "stick"

Thank you very much with persevering with me through this thread. That was exactly the problem.

Is there a way to have a notification that the website visitor should update to the latest flash player for the gallery to function correctly?

Is that a downfall of using these galleries, that people have to install/upgrade flash?

Thank you.

Re: Gallery seems to "stick"

If use the swfobject embed method (this method does not support the nonflash/moblile viewer) you can specify the minimum flash version using the embed code, otherwise you would have to wire or find a script that tests the flash version.

Mike Richards
SimpleViewer Support Team.