Topic: Unable to Edit Existing Gallery

Hi I am a brand new user of SimpleViewer 2 Pro.  I have made a couple of galleries, none of which look like I expect them to so I am wanting to edit them to see if I can get closer to what I am wanting.  When I navigate to the SimpleViewer folder on my local drive, I see both the gallery.xml and the index.html files as well as the various folders, but both of the files are grayed out and inaccessible.  Please help.

Re: Unable to Edit Existing Gallery

To edit a SimpleViewer gallery using svBuilder-Pro, start up svBuilder-Pro, click 'Open Gallery...', select the gallery folder itself (not any of the files or folders within) and click OK.
svBuilder-Pro has a live preview so that you can see what your gallery looks like as you make changes to the options via svBuilder-Pro's interface.
See here for details: http://simpleviewer.net/simpleviewer/pr … uilderpro/

You could also edit your gallery by opening up the gallery's XML file in a plain text editor and adding the options you'd like to use as attributes to the opening <simpleviewergallery> tag.
See here for details: http://simpleviewer.net/simpleviewer/pr … tions.html

Steven Speirs
SimpleViewer Support Team.

Re: Unable to Edit Existing Gallery

Hi Steven,

Thank you so much ... I was just so confused and getting frustrated, but now it is working.

Michelle

Re: Unable to Edit Existing Gallery

I'm unable to open an exising gallery.

I read the stream of messages regarding being unable to open an existing gallery.  As some users said, they can see the gallery.xml file on the comuter but when they open the Simpleviewer Pro and choose "open existing gallery", the gallry.xml doesn't show up at all.  All other files are there except that one.

Many said "ok, solved the problem thanks" and never said how they solved it.  I can't open my existing gallery to edit it.

What am I doing wrong?  If a person solves the problem before someone posts an answer, it would be lovely if they shared the solution with the rest of us.

Re: Unable to Edit Existing Gallery

@famtrudel

In order to open an existing gallery in svBuilder-Pro, you should browse towards and select the gallery folder before clicking 'OK' (ie. the folder containing the 'gallery.xml' file, not the 'gallery.xml. file itself).

Steven Speirs
SimpleViewer Support Team.

Re: Unable to Edit Existing Gallery

Ok.  On my desktop I have a folder called SimpleViewer in which I have all my Simple Viewer files such as:

file=svcore
file=thumbs
file=viewerimages
gallery.xml
index.html

I've already loaded the gallery in my webpages and it works nicely but the background remains black while I thought I'd asked it to be white. 

I was able to make changes to captions and photos directly on the xml sheet but I need to change the background color.  I did attempt to do it from the xml sheet in the style section but it wasn't obvious and would rather go back to using the viewer to make the changes.  I'll need to do this in future anyway so I'd better learn how to go back and edit now.

Re: Unable to Edit Existing Gallery

Oops, forgot to mention that when I do only choose the SimpleViewer folder, I get the spin (not responding) and nothing happens.  Besides, the folder just opens up to reveal all files (without showing either the index or the gallery).  I did create a folder within the SimpleViewer file called Gallery (with the xml file inside) but that didn't work either.

Re: Unable to Edit Existing Gallery

On my desktop I have a folder called SimpleViewer in which I have all my Simple Viewer files such as:

file=svcore
file=thumbs
file=viewerimages
gallery.xml
index.html

Have you renamed your 'images' folder to 'viewerimages'?
If so, you would also need to rename the imageURLs (the paths to the images) within the 'gallery.xml' file.

I need to change the background color

The background color can be changed via the backgroundColor Embed Code Parameter in the simpleviewer.load() function in the gallery's HTML index file ('index.html').

I did create a folder within the SimpleViewer file called Gallery (with the xml file inside) but that didn't work either.

The 'gallery.xml' file should be directly in the root of the gallery folder (not within a subfolder).

Steven Speirs
SimpleViewer Support Team.

Re: Unable to Edit Existing Gallery

Yes, I did rename it viewerimages and changed all the paths in the xml file.  Everything is working wonderfully so far.  I had to change the file name because my website already had a file named images.

The gallery.xml is not within a sub folder. It sits directly in the SimpleViewer folder as explained in my last post. 

When I choose "open existing gallery" and click on SimpleViewer folder, which contains the xml file, on my desktop, nothing happens.

The only thing I can think of is that I changed the name of the "images" folder after I save the file.  Is it possible that it just doesn't recognize the file anymore. I did use the "find and replace" and didn't miss any on the xml file but the SimpleViewer might still be looking for "images".

Re: Unable to Edit Existing Gallery

When I choose "open existing gallery" and click on SimpleViewer folder, which contains the xml file, on my desktop, nothing happens.

Please ensure that you are using the latest version of svBuilder-Pro (v.2.2.0) and Adobe Air (v3.0).
Please see this page regarding Upgrading SimpleViewer-Pro and svBuilder-Pro: http://simpleviewer.net/simpleviewer/pr … grade.html
the latest version of Adobe Air can be downloaded from this page: http://get.adobe.com/air/

If this does not help, please try the following:
1) Close svBuilder-Pro
2) Delete this folder:
Mac: /Users/your_username/Library/Application Support/Adobe/AIR/svBuilder-Pro
PC (XP): C:\Documents and Settings\your_username\Application Data\Adobe\AIR\ELS\svBuilder-Pro
PC (Vista, Win 7): C:\Users\your_username\AppData\Roaming\Adobe\AIR\ELS\svBuilder-Pro
3) Restart svBuilder-Pro

Steven Speirs
SimpleViewer Support Team.

Re: Unable to Edit Existing Gallery

I got it in the end.  The viewer was looking for images so I changed all the names in the gallery.xml file from "viewerimages" to just "images" and they loaded BUT, the viewer only loaded the first 49 photos when there are actually 191 photos.

No biggy though because I just added new photos directly into the gallery.xml file and everything is fine.

In other words, editing the files directly without using the SimpleViewer Pro is better for me.