Topic: Struggling Getting Started

I'm struggling getting started with this plugin  sad

All installed fine, but when I click the 'Add Simpleviewer Gallery' button I get:

Forbidden
You don't have permission to access /wp-content/plugins/wp-simpleviewer/config.php on this server.

If I click the Simpleviewer settings in the Dashboard, I just see .  .

Gallery Id     Last Modified     Post title     Gallery title     Edit     Delete
Gallery Id     Last Modified     Post title     Gallery title     Edit     Delete

No option to add galleries?

Any ideas what I'm doing wrong here? I'm running from my Win7x64 machine (Apache), all other websites, blogs and forums running just fine.

Thanks

Re: Struggling Getting Started

Nobody have any ideas?  neutral

Re: Struggling Getting Started

Have you tried checking the file permissions on the 'wp-content/plugins/wp-simpleviewer/' folder?
After installing WP-SimpleViewer, the default permission for this folder in my installation are 751.
Whatever yours are, you could try changing them to 777 to see if it makes a difference.
It may also be worthwhile re-downloading WP-SimpleViewer from this page: http://www.simpleviewer.net/simpleviewe … pleviewer/
... to ensure that you have the latest version and try reinstalling it (after deactivating and uninstalling your current version).

Steven Speirs
SimpleViewer Support Team.

Re: Struggling Getting Started

Thanks for the response Steven.

As I mention, I'm running this on Windows 7 64bit (WAMPserver), so I'm unsure how to apply a Winx64 equivalent of chmod 777 on a file. I have, however, set all users to have Full Control over the file and unticked 'Read Only'.

I've also tried redownloading the plugin (from your location) as well as deactivating (not deleting) all other plugins.

Any advice appreciated before I start from scratch, which I'd like to avoid if possible.

Re: Struggling Getting Started

From the lack of responses, I can only assume that this is not a common error or one that anyone here has any knowledge of. I guess my best option is to either start with a fresh install or move on to another gallery.

Re: Struggling Getting Started

A fresh install might be a good idea.
In the first instance, try installing WordPress (and then WP-SimpleViewer) into a new folder to prevent any interference with your existing WordPress installation.

If you continue to experience difficulties with WP-SimpleViewer, an alternative would be to build your gallery with svBuilder, upload the entire gallery folder to your web server and embed the gallery in a WordPress post using on of these 2 methods.
When entering the embedding code in your post, choose 'HTML' rather than 'Visual' as the method of entry.

Steven Speirs
SimpleViewer Support Team.

Re: Struggling Getting Started

If you are getting a permissions error on your Windows server, you will need to resolve that first. Unfortunately we cannot provide support for these kind of errors.

Felix Turner
SimpleViewer Support Team.

Re: Struggling Getting Started

It's not an error that I've encountrered with any other plugins, nor other blog, forum or database software that's running on this server, so I'd expect same response from other providers. It's fellow end users that are more likely to have encountred such an error.

Steven - appreciate the suggestions, thank you.

Re: Struggling Getting Started

I encountered this error and ended up here after searching google for a solution.

I eventually found a solution and discovered this is not a file permissions problem but a .htaccess problem. In our .htaccess file at the root of the Wordpress installation I discovered...

<Files "config.php">
Order Allow,Deny
Deny from All
</Files>

As I did not want to remove this for security reasons, I modified the plugin for any reference to config.php to config2.php and moved the file in the plugin folder. This fixed the issue for me.

Re: Struggling Getting Started

@ludup

Thank you for investigating your problem and sharing your solution.

Steven Speirs
SimpleViewer Support Team.