Topic: Upgrading a SV Slideshow to SV-Pro Slideshow

In this site I had previously used SimpleViewer for a Slideshow for the Home page, and then a separate Gallery for the Gallery page.  These were both Flash.

I have upgraded to SimpleViewer Pro v2 and am currently working on upgrading both the Gallery and the Slideshow.

In my site, the folder for the slideshow, is /slideshow/ and it contains a file slideshow.xml.  I cannot remember if I renamed gallery.xml to slideshow.xml or if that is in fact the original SimpleViewer produced file.

When I use svBuilder and select the /slideshow/ folder it responds that no gallery.xml is present.  So I renamed slideshow.xml to gallery.xml but when I select the /slideshow/ folder in svBuilder it opens to Add Images with no images existing.

What do I need to do to convert this (old) slideshow.xml to gallery.xml for non-Flash Mobile use?

The xml file can be seen at:
http://studiokaufman.com/site/propertyL … deshow.xml

the site address is:
http://studiokaufman.com/site/propertyL … index.html

Thank you.

Re: Upgrading a SV Slideshow to SV-Pro Slideshow

The XML file itself is OK.
Try moving your image folder to the same directory as the XML file (rather than back a level, as indicated by the '../' at the beginning of each 'imageURL' path) and change the 'imageURL's in the XML file to reflect this change.

Steven Speirs
SimpleViewer Support Team.

Re: Upgrading a SV Slideshow to SV-Pro Slideshow

Thank you Steven,

In reviewing the existing folder structure of this (project) website I see that what I had done originally when I fist made the SimpleView Slideshow and Gallery was this:

root/gallery/images

root/slideshow/images

...but I then realized that the images used by the gallery and the slideshow are the same.  so in my (original) slideshow.xml the path to the images was ../gallery/images/

Now in working with svBuilder for SV Pro I see we now have the /svcore/ folder (which I did not have in the "old" version.  And it contains a file "full.html"  which contains a reference to gallery.xml
{galleryURL: parameters.galleryURL || 'gallery.xml'});

So...my big question is: I want to clean up my folder structure--out with the old and in with the new, what should be the proper folder structure AND naming of the .xml files in order to have two SimpleViewer "galleries" in the same site (as I have here, one being a slideshow only and the other being a gallery with thumbnails.)

Thank you,

Dan

Re: Upgrading a SV Slideshow to SV-Pro Slideshow

When creating a gallery with svBuilder, each gallery is a self-contained entity with all the required files in a single folder.
I would keep each gallery separate (in its own folder) and keep all files and folders with their default names.
Index Page = index.html
XML File = gallery.xml
Images Folder = images
Thumbs Folder = thumbs
This is just a recommendation and not essential but it keeps things organized (and keeping the gallery as svBuilder has created it requires less work, ie. no modifications or renaming required).

Do not worry about the reference to 'gallery.xml' in the 'full.html' file.
The first part of the 'OR' statement you quoted takes care of XML files that are named otherwise.
The 'svcore' folder must remain named as 'svcore' and the contents of this folder should remain unmodified.

With each gallery in its own folder, you can upload the gallery folders in their entirety and embed them in your web site by using one of these 2 methods.

See also 'Embedding Multiple Galleries' here: http://simpleviewer.net/simpleviewer/su … l#multiple

Steven Speirs
SimpleViewer Support Team.

Re: Upgrading a SV Slideshow to SV-Pro Slideshow

Thank you Steven,  I can do that. smile

Dan

Re: Upgrading a SV Slideshow to SV-Pro Slideshow

Thank you Steven,  I have made the folder and pathing changes you recommended and svBuilder now finds the images when I Start a new Gallery and point to my /slideshow/ folder.

I customized only the background color for this "slideshow" gallery and then uploaded index.html, gallery.xml, and the new /slideshow/images/ folder.

The update SV Pro v2 slideshow gallery work fine in a regular computer browser, however when I view it in my iPad it does not come up as a slideshow but is showing a thumbnail page just like the /gallery/ folder gallery. but it is showing the background color I re-set for the /slideshow/ gallery so I'm assuming it is seeing the correct gallery.xml file.

The xml file is visible at:
http://studiokaufman.com/site/propertyL … allery.xml

and the site is at:
http://studiokaufman.com/site/propertyL … slideshow/

Are you able to view this on a Mobile device such as an iPad?
As I said, it is working as expected in a regular browser,
but on the iPad I am not getting the correct output, I'm getting a thumbnail page and there are no thumbnails at all for this /slideshow/ gallery

I have cleared the Safari cache on the iPad numerous times, but still get the same results when I refresh the page.  I have also powered down the iPad, restarted, cleared the cache again just to be sure, and...sitll get the same "thumbnail view" for a slideshow with no thumbnails.


Thank you,

Dan

Re: Upgrading a SV Slideshow to SV-Pro Slideshow

Please see this FAQ regarding the Mobile Player layout: http://simpleviewer.net/simpleviewer/su … l#mobile_1

There are very few options available to configure the Mobile (non-Flash) Player and an automated slideshow is not possible.
http://simpleviewer.net/simpleviewer/pr … tml#mobile

You can, however, set mobileShowThumbs="FALSE" in order to skip the thumbnail page and display the first image when the gallery is viewed on a mobile device.

Steven Speirs
SimpleViewer Support Team.