Topic: v2.1.3 did not work in a frame on iphone

i update to the version sv 2.1.3 and now the simpleviewer mobile player didnt work in a frame.

you can show on my site www.deniskuhlmey.de

i the older version that works perfect,

can you help me?? i cant find any mistake in my config

Re: v2.1.3 did not work in a frame on iphone

you can test it with the water gallery in the portfolio

Re: v2.1.3 did not work in a frame on iphone

I can view your gallery on my iPod Touch if I go directly to the gallery at http://www.deniskuhlmey.de/img/water/index.html
The problem may lie with your <frameset> page at http://www.deniskuhlmey.de/index.html which currently fails validation with the W3C Markup Validation Service.
Your page at http://www.deniskuhlmey.de/index.html currently uses the following code:

<title>Denis Kuhlmey | Photo Sport Travel</title>
<frameset rows="7%,93%" border="0">
  <frame src="menu.html" scrolling="no" frameborder="0" noresize>
  <frame src="photos.html" name="Daten" scrolling="yes" frameborder="0">
</frameset>

Replace it with the following and see if this makes a difference.

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
   "http://www.w3.org/TR/html4/frameset.dtd">
<html>
    <head>   
        <meta http-equiv="content-type" content="text/html; charset=utf-8">
        <title>Denis Kuhlmey | Photo Sport Travel</title>
    </head>
    <frameset rows="7%,93%">
        <frame src="menu.html" scrolling="no" frameborder="0" noresize>
        <frame src="photos.html" name="Daten" scrolling="yes" frameborder="0">
    </frameset>
</html>
Steven Speirs
SimpleViewer Support Team.

Re: v2.1.3 did not work in a frame on iphone

hi steven,
many thanks for the fast support.
but is no difference, in new window it works but not in the frame.

have you any other idea?

Re: v2.1.3 did not work in a frame on iphone

I can now view your gallery in the <frame> on my iPod Touch by going to http://www.deniskuhlmey.de and clicking on 'Water' (and scrolling down a little).
Try clearing your browser's cache before reloading the gallery.

Steven Speirs
SimpleViewer Support Team.

Re: v2.1.3 did not work in a frame on iphone

yes you are right, i was too fast. sorry.
but it have another look than the gallery when i open it in a new window. and when i choose a picture i can slide but theres no menu on the top.
is it not possible to open the gallery in a frame like in a new window on mobile devices?

Re: v2.1.3 did not work in a frame on iphone

ok it looks so:
when i zoom in on the iphone that the menu is not to see and then ich choose a picture the view is not optimal an no menu is to see. but when i zoom totally out on iphone and choose a picture it looks good and also i can see the menu.

sorry for my bad english, i hope you understand it.

Re: v2.1.3 did not work in a frame on iphone

Try fixing the errors on all your HTML pages.
Your 'menu.html' page has no Doctype Declaration: http://www.w3.org/QA/2002/04/valid-dtd-list.html
Your 'photos.html' page has no opening <html> tag.
Check your pages with the W3C Markup Validation Service and fix any errors reported.
Once the errors are all fixed and the code validates, different browsers will render your pages with greater consistency and the layout issues may be fixed in the process.

Steven Speirs
SimpleViewer Support Team.

Re: v2.1.3 did not work in a frame on iphone

ok i have fixed most oft the erros, but now it works also not on new window.
is it possible that it is problem i use ttg and export the gallery from Lightroom?

Re: v2.1.3 did not work in a frame on iphone

You could try removing the CSS section from your 'img/water/index.html' file in case something is interfering with the CSS used for SimpleViewer's Mobile Player.
You could also try embedding SimpleViewer into an <iframe> instead of using a <frameset>.

Steven Speirs
SimpleViewer Support Team.

Re: v2.1.3 did not work in a frame on iphone

yes beacause of the css section the mobile gallery work not correct. the css section come from the ttg plugin in lightroom is this is a bug?
if i delete the css section the gallery works in a new window but not in the frameset.
i will test it with a iframe.

Re: v2.1.3 did not work in a frame on iphone

maybe im stupid with the embedded of a sv gallery, but it also dont work in a iframe on my page.

www.deniskuhlmey.de/img/water/index.html

Re: v2.1.3 did not work in a frame on iphone

i build this gallery with svbuilder now, i dont use ttg in lightroom.

Re: v2.1.3 did not work in a frame on iphone

Take a look at the SimpleViewer Embedding Guide here: http://simpleviewer.net/simpleviewer/su … dding.html
The section entitled Using a Resizable Gallery with a Header has downloadable examples which you can download, examine and modify for your own needs. You could, perhaps, use one of the examples as a template and include your links in a header (in the 'Header Example') or a side menu (in the 'Side Menu' example).
There is also a section entitled Multiple Galleries which should help you embed multiple galleries on separate HTML pages or on one HTML page.

Steven Speirs
SimpleViewer Support Team.