Topic: XML generated by PHP

I have set up a php script that generates an xml file for Tiltviewer with Flickr url's from a set id, for example; http://2011.barrow6fc.org.uk/about/gall … 6735358279

But when I try and use this as an xml file in tiltviewer it wont load any of the images, could you possibly see why not?

If you visit; http://2011.barrow6fc.org.uk/about/gall … 6735358279 you can see that it shows no error messages or loading blank images. Is the XML not formatted correctly or is there something else the matter?

Cheers

Re: XML generated by PHP

Rather than use Flickr URLs in the XML file, try using the Flickr options in the embedding code, eg:

fo.addVariable("useFlickr", "true");
fo.addVariable("user_id", "57955344@N06");        
fo.addVariable("tags", "tiltviewer");

Tag the images in Flickr that you wish to display in your TiltViewer gallery and specify these tags in you embedding code as above.

Steven Speirs
SimpleViewer Support Team.

Re: XML generated by PHP

I can see how that would be more simple but it is more difficult for the end user and i would prefer if i could organise the photos into sets. Surely there shouldn't be a problem with the way i have done it?

Cheers

Re: XML generated by PHP

I'm not sure but there may be a cross-domain issue with http://static.flickr.com/ URLs which would explain why your images are not being displayed.
See here for details: http://simpleviewer.net/simpleviewer/su … trouble_11
(The FAQ is in the SimpleViewer support section but the problem applies equally to TiltViewer.)

Steven Speirs
SimpleViewer Support Team.

Re: XML generated by PHP

Unfortunately, I doubt Flickr would give me FTP access to upload to static.flickr.com  lol

How come the 'useFlickr' option works without the crossdomain.xml file?

Re: XML generated by PHP

I don't know how Flickr store their images but the 'useFlickr' option uses a Flickr API search to fetch the images and Flickr may serve the images from a different server (not static.flickr.com) for API search results, one which is configured to allow the images to be used in other domains.

Steven Speirs
SimpleViewer Support Team.

Re: XML generated by PHP

I managed to get this working, it was becuase the php flickr framework i was using just gave the link as static.flickr.com and left flickr to redirect to the appropriate farm e.g. farm4.static.flickr.com I'm guessing Tiltviewer didn't like the redirect for some reason.

Any way i got it working fine by adding the farm number to the begining of the url so that flickr didnt need to redirect.

But just recently i seem to be having problems with it again, some images don't come through at all. And some times entire sets don't come through.

Here is a link to my xml; http://www.barrow6fc.org.uk/about/galle … 7176637232
(the id param dictates what flickr photoset to retrieve)

and here it is not showing; http://www.barrow6fc.org.uk/about/galle … 7176637232

An example of certain images not showing up can be seen here;
http://www.barrow6fc.org.uk/about/galle … 6957963805
http://www.barrow6fc.org.uk/about/galle … 6957963805
(I can't seem to find any correlation between the pictures that aren't showing)


Can any one shed any light on why this has suddenly stopped working? Has flickr changed something at there end recently?

Cheers

Re: XML generated by PHP

Please see this thread for details: http://www.simpleviewer.net/forum/viewt … p?id=14534

Steven Speirs
SimpleViewer Support Team.