Topic: Amazon S3

Trialling popping my galleries on Amazon's S3 servers ... all seems fine BUT ... if I embed the gallery it displays fine but clients can't download the files; if I use an iFrame then they can? I'd rather go down the embed route anybody know anything about this?

Last edited by howlingbasset (2011-06-15 08:56:27)

Re: Amazon S3

if I embed the gallery it displays fine but clients can't download the files

If you are talking about the Download Button when the gallery is displayed using Adobe Flash Player, please ensure you are using the latest version of SimpleViewer Pro (v2.1.3) as there was a bug in a previous version (v2.1.1) relating to the Download Button.
Also, you could try defining the imageURL entries in the gallery's XML file as absolute (rather than relative) URLs.

Steven Speirs
SimpleViewer Support Team.

Re: Amazon S3

Thanks but I'm running the latest version. Everything works and displays but can't download from Amazon S3 if simpleviewer is embedded, other servers are fine ... and works from amazon if I pop the gallery in an iFrame???

Re: Amazon S3

Please post a URL to your gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: Amazon S3

Hi ... I've popped a test at ...

http://www.howlingbasset.com/mywedding/test.html

... ones embedded and the others an iframe

Thanks for checking

Andy

Re: Amazon S3

Try adding a trailing slash to your baseURL, ie:

flashvars.baseURL = "https://s3-eu-west-1.amazonaws.com/howlingbasset/weddings11/katrina-and-steve/";

Also, you could try defining the imageURL entries in the gallery's XML file as absolute (rather than relative) URLs, eg:

  <image imageURL="https://s3-eu-west-1.amazonaws.com/howlingbasset/weddings11/katrina-and-steve/images/Katrina and Steve 001.jpg"
    thumbURL="thumbs/Katrina and Steve 001.jpg"
    linkURL="images/Katrina and Steve 001.jpg"
    linkTarget="_blank">
    <caption><![CDATA[]]></caption>
</image>
Steven Speirs
SimpleViewer Support Team.

Re: Amazon S3

Thanks for the quick reply.

Trailing slash didn't work

Changed image number 1 with the full url in the xml file .. no joy I'm afraid

Re: Amazon S3

can you try with regular http instead of https?

Felix Turner
SimpleViewer Support Team.

Re: Amazon S3

You clever person ... that's worked a treat!!!

Many thanks for that.

Andy