Topic: Mobile Thumbnails

I love the showMobileThumbs option introduced recently! However, I was wondering if it was possible to showMobileThumbs = true but, not initially. As in, when the gallery loads on mobile, it starts with the first image, large, and the thumbs can be accessed if the viewer is interested in them. some sort of showMobileThumbsFirst = false option maybe?

PS SimpleViewer 2 rocks my world! Hello flash and mobile nirvana!!!!

Thanks!!

Re: Mobile Thumbnails

In order to show an image first, rather than the grid of thumbnails, set the firstImageIndex option: http://simpleviewer.net/simpleviewer/pr … ml#general
To initially show the first image but to have the thumbnails accessible through the Thumbnail Button on the Button Bar, use the following in your gallery's XML file:

<simpleviewergallery
    firstImageIndex="0"
    mobileShowThumbs="true"
    title="SimpleViewer-Pro Gallery"
>

[Post split from 'Post Feedback and Feature Requests Here!' forum.]

Steven Speirs
SimpleViewer Support Team.

Re: Mobile Thumbnails

Steven,

Thanks for the help!!! It worked... but I needed to modify some other code that was overriding the setting causing the thumbs to display by default... AWESOME!! Thanks!

Re: Mobile Thumbnails

Question: when using mobile simpleviewer mode, the hash doesnt update the URL.. should it? (works great with the Flash version) Also I think I'm having an issue with the API reporting to the new google tracking code, but may need to wait another 24 hours for full results.

Re: Mobile Thumbnails

when using mobile simpleviewer mode, the hash doesnt update the URL.. should it?

Yes, though you may need to refresh the page or enter the URL into a new tab/window.

Steven Speirs
SimpleViewer Support Team.

Re: Mobile Thumbnails

You're FAST! Thank you smile

Oh, OK. That's fine for me. If I directly access a hash such as /gallery/g1/#4, it works on mobile, but when swiping, it does not update the hash but I'm not so concerned with that. It works perfect on the Flash version!

As far as Google Analytics is concerned, I'm not sure that the API is reporting properly to the GA tracking code. Where might I look to help troubleshoot?

Thanks a million!

Re: Mobile Thumbnails

Tracking should work fine as long as you have followed these instructions: http://simpleviewer.net/simpleviewer/pr … l#tracking
Being that tracking events may take up to 24 hours to show, I would check this time tomorrow before looking to troubleshoot a problem that hopefully does not exist.

Steven Speirs
SimpleViewer Support Team.