Topic: file references- wont load new images on second gallery

Hi
I had trouble with the first installation of a photo gallery, and in the end I needed to place all the files in the root directory for it to work, and to change the file locations written in the gallery.xml. Which I really hate because I want the files to be neatly stored in a folder. Now I wish to have another photo gallery and of course I have the same problem, the new gallery just shows the first images that are in the root directory.
Am I missing editing a file? I want the new images and files including svcore in a folder named services_images. The pages where the galleries code is placed are in the root directory (services.htm). I have edited the file references in gallery.xml to be
services_images/images/XXXX.jpg and services_images/thumbs/XXXX.jpg  respectively.
services_images/svcore/XXXX.jsp  etc etc...

Is there another file I need to edit? because it just ignores the directory I have told it to look in and still shows the root directory images. It also cant find the sw objects modified file. I'm not too worried about that at the moment because the clients website is in my directory and not on their own.

Here is the page in question
http://bunburywebdesign.com/clients/bva … rvices.htm

the first gallery is the index.htm file.

The code created after the gallery made is useless. No matter where I save the new files the svcore/js/etc is always the same. I have saved the gallery here C:\Aweb\bwdnew1\clients\bvametal\services_images

Can anyone please help, its giving me a major headache. Thanks

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "600", "480", "222222", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Re: file references- wont load new images on second gallery

I want the files to be neatly stored in a folder.

You can create individual galleries using svBuilder-Pro and keep each gallery as a self-contained entity, each in its own folder.
In doing so, you will not need to edit the paths to the images in the gallery's XML file.
If your have a gallery folder ('services_images') alongside the HTML page into which you'd like to embed the gallery ('services.htm'), then you can use the baseURL option to point towards the gallery. The embedding code in the HTML file ('services.htm') would be:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="services_images/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "services_images/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Instructions on using baseURL can be found here: http://simpleviewer.net/simpleviewer/su … html#embed

Steven Speirs
SimpleViewer Support Team.

Re: file references- wont load new images on second gallery

Steven,
I am having the same problems - sorry I added a new thread about this.

<script type="text/javascript" src="/gallery-2/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
[b]flashvars.baseURL = "gallery-1/";[/b]
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "685", "100%", "222222", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

I tried adding the flashvars.baseURL = "gallery-1/"; as you had mentioned but getting a xml path error?
My gallery generated in svBuilder is in the folder gallery-1.

My test page: http://www.cms2.primaveraphoto.com/gallery-test.html

Thanks Steven

Mark

Re: file references- wont load new images on second gallery

@MarkPrima
Please see my reply to your post in this thread: http://www.simpleviewer.net/forum/viewt … p?id=12979

Steven Speirs
SimpleViewer Support Team.