Topic: Error in my first try

I took the code generated when I saved my gallery (I have the Pro version of SV) I placed the code in my page - but now not seeing anything??

My gallery is in a directory called "Gallery-2" which is in the root of my server.
This is a link to my test gallery: http://www.cms2.primaveraphoto.com/gallery-test.html

I have tried playing with the path to simpleviewer.js?

Any ideas?

Thanks so much!!!

Last edited by MarkPrima (2011-06-21 20:32:06)

Re: Error in my first try

To include the flashvars, you must include them as a parameter in your embedding code.
See here for details: http://simpleviewer.net/simpleviewer/su … tml#params
Instead of:

<script type="text/javascript" src="gallery-2/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "gallery-1/";
flashvars.galleryURL = "gallery-1/gallery.xml";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "685", "100%", "222222", true);
});
</script>
<div id="sv-container"></div>

... try:

<script type="text/javascript" src="gallery-1/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "gallery-1/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "685", "100%", "222222", true, flashvars);
});
</script>
<div id="sv-container"></div>
Steven Speirs
SimpleViewer Support Team.

Re: Error in my first try

Thank you Steven - I realized I forgot to add "simpleviewer.load("sv-container", "685", "100%", "222222", true);" - I didn't have true