Topic: Multiple galleries - same page - still can't get it

Apologies - I see that this has come up before, but I've done my best to follow the various advice and still see the same images in both galleries.

In particular, I was following this thread -

http://www.simpleviewer.net/forum/viewtopic.php?id=9103

______________________________________

My code -

<div class="green-row">

<span class="right"><img src="../site images/red-quote.gif" alt="" />TEXT HERE</span>

<script type="text/javascript" src="swfobject.js"></script>
<div id="flashcontent">AutoViewer requires JavaScript and the Flash Player.
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>   
<script type="text/javascript">
var fo = new SWFObject("autoviewer.swf", "viewer", "700", "465", "8", "#000000");
  fo.addVariable("xmlDataPath", "gallery.xml");
fo.write("flashcontent");   
</script>

</div>

<div class="green-row">

<span class="right"><img src="../site images/red-quote.gif" alt="" />TEXT HERE</span>

<script type="text/javascript" src="swfobject.js"></script>
<div id="flashcontent2">AutoViewer requires JavaScript and the Flash Player.
<a href="http://www.macromedia.com/go/getflashplayer/">Get Flash.</a></div>   
<script type="text/javascript">
var fo = new SWFObject("autoviewer.swf", "viewer", "700", "465", "8", "#000000");
  fo.addVariable("xmlDataPath", "gallery2.xml");
fo.write("flashcontent2");   
</script>

</div>
__________________________________

I've checked and double-checked that both xml files show the correct path to different files in the images folder. Both galleries show the same images (from "gallery.xml").

Is advice/diagnostic only possible with the site online? Am I missing anything obvious?

I'm sure I've done this before with Simpleviewer Pro...

Thanks

Re: Multiple galleries - same page - still can't get it

Use xmlURL instead of xmlDataPath. (xmlDataPath is a SimpleViewer v1.x option.)
http://simpleviewer.net/autoviewer/supp … .html#html
eg. use:

fo.addVariable("xmlURL", "gallery2.xml");
Steven Speirs
SimpleViewer Support Team.

Re: Multiple galleries - same page - still can't get it

That works perfectly. You're a stud. Thanks.

Re: Multiple galleries - same page - still can't get it

Steven Speirs wrote:

Use xmlURL instead of xmlDataPath. (xmlDataPath is a SimpleViewer v1.x option.)
http://simpleviewer.net/autoviewer/supp … .html#html
eg. use:

fo.addVariable("xmlURL", "gallery2.xml");

I have the same problem... I've tried to change the path in html and change the name of xml, but the gallery appears white (it's the background color of the div div where I embedded Autoviewer), with all the buttons of Autoviewer, without photos.
The strange thing is that I can see the photos back just renaming the file as "gallery", its default.

Re: Multiple galleries - same page - still can't get it

@stellastellina
Please post a URL to your gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: Multiple galleries - same page - still can't get it

Steven Speirs wrote:

@stellastellina
Please post a URL to your gallery so that we can take a look.

It's pretty weird... Now that I've uploaded it images are visible. http://www.caroprocione.com/stellastell … atti-3.htm

So this code is right:

  <div id="flashcontent">Per vedere la galleria di foto è richiesto Adobe Flash. <a href="http://www.macromedia.com/go/getflashplayer/">Scaricate Adobe Flash.</a> Se Flash è già installato, <a href="index.html?detectflash=false">fate clic per visualizzare la galleria</a></div>    
<script type="text/javascript">

        var fo = new SWFObject("viewer.swf", "viewer", "100%", "100%", "8", "ffffff" );

        fo.addParam("scale", "noscale");

        fo.addParam("quality", "best");
        
        fo.addParam("wmode", "opaque");

        fo.write("flashcontent");

        fo.addVariable( "langOpenImage", "Apri immagine in nuova finestra");

        fo.addVariable("xmlURL", "ritratti.xml");

</script>

I think I've made some mess somehow smile
Sorry for false alarm! Thank you for your helpfulness!

Re: Multiple galleries - same page - still can't get it

I'm glad you seem to have it working but the lines:

fo.addVariable( "langOpenImage", "Apri immagine in nuova finestra");
fo.addVariable("xmlURL", "ritratti.xml");

... should come before the line:

fo.write("flashcontent");

... in your embedding code.

Steven Speirs
SimpleViewer Support Team.