Topic: Embed issue. Totally Stumped!!

I'm trying to embed simpleviewer into my site. I am using pixelpost and am not sure if there is something not compatible between the two. Everything is uploaded correctly, but the viewer doesn't seem to want to show. Please could someone help me out. Here is the link

http://namtranphoto.com/index.php?x=browse

Re: Embed issue. Totally Stumped!!

I GOT IT!!!!! Such a good feeling!

Re: Embed issue. Totally Stumped!!

Currently, your gallery will display a 'Gallery XML Not Found.' message if it is viewed using the Mobile Player (on mobile devices and in non-Flash-enabled browsers) if you go to http://namtranphoto.com/index.php?x=browse
However, the gallery will be displayed OK if you go to http://www.namtranphoto.com/index.php?x=browse.
This is due to the path to the 'simpleviewer.js' file and the baseURL being defined using absolute URLs to www.namtranphoto.com
'namtranphoto.com' and 'www.namtranphoto.com' are different domains ('www.namtranphoto.com' being a subdomain of 'namtranphoto.com').
See here for details: http://simpleviewer.net/simpleviewer/su … trouble_11
The solution is to use relative paths within your embedding code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="templates/spotless/Life/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "templates/spotless/Life/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container1", "75%", "70%", "222222", true, flashvars);
});
</script>
<center><div id="sv-container1"></div></center>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.