Topic: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Hi, I've found similar threads but none solve my problem.

I'm using wordpress with Photocrati theme and have installed the simpleviewer pluging which works perfectly - until I update to the pro version as per the instructions on the support site.

Once I upload the folder in the instructions, overwriting the old version, I simple get:
SimpleViewer requires JavaScript and the Flash Player - when I refresh the page

Here's the page link
http://www.jpstevenson.co.uk/photography/?page_id=57


I've updated my Java and Flash plugins just to be sure I have latest, and repeated the process twice with the same results.

Using Windows 7, Firefox 4, Photocrati theme (Which I feel must support pro if it supports the free version)

Thanks for your help, and the great viewer, it's long been a favorite of mine and I'm looking forward to getting it working on my wp site.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

I notice that you are using SimpleViewer Pro v2.1.2.
Please upgrade to v2.1.3 as several bugs have been fixed.
Upgrades are free within the same major version number so you can download the latest version using the link in your purchase email.
Instructions for upgrading WP-SimpleViewer from SimpleViewer Standard to SimpleViewer Pro can be found here: http://simpleviewer.net/simpleviewer/su … iewer/#pro

Also, try temporarily disabling your Photocrati theme (and use the default TwentyTen theme) to see if this does make a difference (although, like you, I suspect it will not).

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Thanks for the update tip Steve, I wasn't aware there was a new version and that has fixed the problem, it now works just fine.


I'd like to ask another question but will post that in a separate thread.

Thanks again for the prompt reply!

James

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

It looks like it also worked for me. thanks!!

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Im having this issue this morning. I upgraded to the pro version on 2.3.0 with WP 3.3.2. All the galleries that associate to my xml's are showing the "SimpleViewer requires JavaScript and the Flash Player" message now. How can I fix this? Its effecting our business big time. Any help or direction would be great. I can the html from one of the pages if needed. I am using the short form and it was working fine until now. Thanks. My name is Troy by the way. Thanks

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

@computercreationsnw

I upgraded to the pro version on 2.3.0 with WP 3.3.2.

If it was working fine until you tried to upgrade WP-SimpleViewer from SimpleViewer-Standard to SimpleViewer-Pro, then perhaps you have inadvertently uploaded the Pro 'svcore' folder to an incorrect location.
Check that you have followed the Upgrading to SimpleViewer-Pro instructions and that the 'svcore' folder has been uploaded to the correct location.
If you continue to experience difficulties, please post the URL to the web page into which the gallery is embedded so that I can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Yes. I have confirmed the location is correct. I should explain better. It was giving this error with the normal WP sinpleviewer so I upgraded to pro. I've confirmed and have a pretty strong understanding of the instructions and it's not working. It stopped working after upgrading to WP 3.3.2. Additionally you can check one of the pages at www.beachhouse1.com  Click on the search properties and then accept terms. It will pull the properties pages into frame and you can see what I mean. Is there anything else I can provide you? Thanks.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Click on the search properties and then accept terms.

I have done this but see no evidence of a SimpleViewer gallery on the resulting page and there also seems to be no embedding code at all when I view the source of the page. Also, I do not see the 'SimpleViewer requires JavaScript and the Flash Player' message.
I should point out that WP-SimpleViewer has been tested with and is compatible with WordPress v3.3.2.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Sorry Steven. You have to click on one of the properties that come up on the "more pictures and details" for each property. That brings up the popup window with the error on it.

Here is a direct : http://properties.beachhouse1.com/1961-s-prom

The problem only started once upgraded to 3.3.2. So there must be an issue. The coding to me on this page does not look like the coding from before for the simpleviewer. I have deleted the whole folder for wp-simpleviewer as a test and reinstalled. No change. Tried installing the standard 2.3.0 version and running the procedure for the upgrade again and no change. Let me know what else I can get you. Thanks

Last edited by computercreationsnw (2012-05-07 21:42:57)

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

Additionally I saw the requirement for calling up on the header.php file. Can you see if this looks right?

i opened in notepad++ to copy and paste

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
    <title><?php
    global $page, $paged;
    wp_title( '|', true, 'right' );
    // Add the blog name.
    bloginfo( 'name' );
    // Add the blog description for the home/front page.
    $site_description = get_bloginfo( 'description', 'display' );
    if ( $site_description && ( is_home() || is_front_page() ) )
        echo " | $site_description";
    // Add a page number if necessary:
    if ( $paged >= 2 || $page >= 2 )
        echo ' | ' . sprintf( __( 'Page %s', 'twentyten' ), max( $paged, $page ) );
    ?></title>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta http-equiv='X-UA-Compatible' content='IE=8' />
    <link rel="stylesheet" type="text/css" media="all" href="<?php bloginfo( 'stylesheet_url' ); ?>" />
    <link rel="stylesheet" type="text/css" href="<?php bloginfo( 'template_url' ); ?>/lightbox-form.css" />
    <script type="text/javascript" language="javascript" src="<?php bloginfo( 'template_url' ); ?>/lightbox-form.js" />
    <?php wp_head(); ?>
</head>
<body>

Thanks...Not sure if any of this will help you.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

The problem could be caused by the following line (not related to WP-SimpleViewer)  in your page:

<script type="text/javascript" language="javascript" src="http://properties.beachhouse1.com/wp-content/themes/beachhouse/lightbox-form.js" />

The <script> tag should be closed with a </script> tag, i.e.:

<script type="text/javascript" language="javascript" src="http://properties.beachhouse1.com/wp-content/themes/beachhouse/lightbox-form.js"></script>


It could be the case that all further <script> references below this line of code (including the one used to load the 'simpleviewer.js' file) are being ignored until the browser finds a closing </script> tag.

If the line of code relating to 'lightbox-form.js' is generated by a plugin, try deactivating the plugin to see if your SimpleViewer galleries then display OK.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer requires JavaScript and the Flash Player (Pro issue only)

That's what the issue was. Some how the header.php got jacked up during the upgrade. Fixed the coding for the script tag and all is working now. Thanks again Steven.