Topic: How to put gallery in a Spry tab?

Every gallery I've made to date has been on its own page. But now I want to add a small gallery within a tab on a Spry Tabbed Panel 2 page in Dreamweaver.

I'll be making several galleries on each page within my site so how do I handle multiple copies of gallery.xml and other associated files?

Thanks in advance for advice,
Jo

Re: How to put gallery in a Spry tab?

Keep each gallery in a separate folder, upload the complete gallery folders to your web server and use the baseURL method of embedding as described here: http://simpleviewer.net/simpleviewer/su … l#external

Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Thanks, I'll give it a go.

Can I have the same gallery on different pages on different domains?

Last edited by boppyqt (2011-07-11 20:54:35)

Re: How to put gallery in a Spry tab?

Yes, but please see this FAQ regarding different domains: http://simpleviewer.net/simpleviewer/su … trouble_11

Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Thanks Steven,
What have I done wrong here? http://tatlerprime.co.nz/weddings_tabs
In my gallery set up I have set the background colour to white and the width to 80%
As you can see the background is grey and the width has blown out of proprotion with the page.
Jo

Re: How to put gallery in a Spry tab?

If I click on the 'Images' tab, the gallery is displayed but the embedding code contains the line:

simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);

... setting the width to 100% (not 80%) and the background color to #222222 (not #ffffff).
Change the above code to:

simpleviewer.load("sv-container", "80%", "100%", "ffffff", true, flashvars);
Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Thanks, I had noticed in the free version that some of my gallery settings did not translate through to the embedded page but obviously it happens here too.

I notice when I edit an existing gallery the tweaks do not save, as in this case with the size and colour.

What percentage do I need to make the width so the embedded gallery will not stretch a 700 px page?

Re: How to put gallery in a Spry tab?

Try giving the <td> into which SimpleViewer is embedded a specific width (700px) and keep the gallery's own width at 100%.
eg:

<td style="width: 700px;">
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.tatlerprime.co.nz/sv_wedding_gallery/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.tatlerprime.co.nz/sv_wedding_gallery/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "ffffff", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
</td>
Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Is there a problem using SV with tabs?

I've created two galleries and saved them in their respective folders: tatlerprime.co.nz/tatler and tatlerprime.co.nz/prime. Navigating to these addresses displays the correct galleries.

Yet I have copied and pasted the code for BaseURL to tabbed pages as:

              <td>
            <!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.tatlerprime.co.nz/prime/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.tatlerprime.co.nz/prime/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "70%", "100%", "ffffff", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED --></td>

and I do not get the expected galleries when I browse to:http://www.tatlerprime.co.nz/venues.html?tab=2 and http://www.tatlerprime.co.nz/venues.html?tab=3

What have I done wrong?

Thanks in advance,
Jo

Last edited by boppyqt (2011-07-18 09:13:02)

Re: How to put gallery in a Spry tab?

Both your galleries are embedded into <div>s named 'sv-container' and you, therefore, have two <div>s with the same name on the same page.
The second gallery (tab=3) is likely to be embedded into the first instance of <div id="sv-container"> which is not visible as it belongs to 'tab=2'.
Try changing:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.tatlerprime.co.nz/tatler/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.tatlerprime.co.nz/tatler/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "70%", "100%", "ffffff", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

... to:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.tatlerprime.co.nz/tatler/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.tatlerprime.co.nz/tatler/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container2", "70%", "100%", "ffffff", true, flashvars);
});
</script>
<div id="sv-container2"></div>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Thanks Steven,
Still not right - the Prime slideshow is still showing Tatler's images.
Jo

Re: How to put gallery in a Spry tab?

Try also giving the 'flashvars' for each set of embedding code a unique name:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.tatlerprime.co.nz/tatler/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars2 = {};
flashvars2.baseURL = "http://www.tatlerprime.co.nz/tatler/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container2", "70%", "100%", "ffffff", true, flashvars2);
});
</script>
<div id="sv-container2"></div>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Thanks Steven, that's got it going now.

Just one other question: is it possible to have the image name hidden BUT have the captions showing? Most of the names of my pics are not very nice so I'd rather not have them displayed, while some have captions that are relevant, or giving credit.

Re: How to put gallery in a Spry tab?

Try setting the following code in your gallery's XML file:

flickrShowTitle="FALSE"
flickrShowDescription="TRUE"
Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Well it worked on the Prime gallery but I pasted the same code in the Tatler one and I still get the image names.

Last edited by boppyqt (2011-07-20 01:48:54)

Re: How to put gallery in a Spry tab?

Your Tatler gallery no longer displays the image names when I view the gallery on my PC.
Try clearing your browser's cache before reloading the gallery.

Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

I have created a gallery on my home tab (spry) for reflexio.com.  I'd really like to create a gallery for each of the other tabs o replace the google widget that i am currently using (and not liking).

Is there a simple way to do this with Dreamweaver, I am a novice Dreamweaver user.

I have created a separate gallery e.g. Black and White, but can't get the gallery to load on the tab.  I am wondering how to direct the simpleviewer to the right xml and right directory.

Thanks in advance.

Re: How to put gallery in a Spry tab?

I am wondering how to direct the simpleviewer to the right xml and right directory.

You can direct SimpleViewer towards a specific XML file by using the galleryURL option.
However, if you plan to upload multiple galleries, it would make sense to upload each gallery as a separate entity (each in a separate folder) and embed the galleries using one of these two methods, ie. using a baseURL to point to the gallery folder or an <iframe> whose 'src' attribute loads the gallery's HTML index page.

Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

Hi Steven

I have used the links and code that you provided... thanks for that, much appreciated.

I was wondering if you could take a look at my page and let me know what I have done wrong.  The gallery is not in the style that I published (I was expecting to see this style...  http://reflexio.com/gallery1/gallery1.html), and I get errors in IE.  Firefox says in can't find the Gallery XML file and doesn't work at all.

I know it is something simple, but I am stumped as to what I have done wrong.

Any assistance is greatly appreciated.

Thanks in advance

John


Update, I changed the path for the simpleviewer.js and now Firefox and Chrome work OK, but IE does not.  I thin I am almost there, but still need some advice.  Thanks again.

Last edited by reflexio (2011-10-21 15:43:56)

Re: How to put gallery in a Spry tab?

Inconsistencies between viewing a web page in different browsers can often be attributed to HTML errors on the page.
Try validating your page with the W3C Markup Validation Service and fix any errors reported.

Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

The W3C identified a few issues with reflexio.com, and i fixed those, but it dit not fix the problem with IE9 not displaying the gallery correctly.  It looks like it is not finding the gallery.xml file and is defaulting to some other standard display format.

I have checked Safari, Firefox and Chrome and they all work OK. Just IE9 that doesn't.

Any advice greatly appreciated, thanks

Re: How to put gallery in a Spry tab?

It looks like it is not finding the gallery.xml file and is defaulting to some other standard display format.

Are you perhaps seeing a grid of thumbnails or large images filling the browser window?
If so, this would indicate that you do not have Adobe Flash Player installed (or enabled) in IE9 and that the gallery is being displayed by the Mobile Player.
Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … trouble_14

Steven Speirs
SimpleViewer Support Team.

Re: How to put gallery in a Spry tab?

...the gallery is being displayed by the Mobile Player.

Exactly, all fixed.... thanks for your assistance, much appreciated.