Topic: Simple Viewer Pro works very differently in differents Browsers

Hello,

I just bought SimpleViewer Pro few days ago.
It is not a good new telling that the gallery is different between the different browsers.
http://www.baudelet.net/val-yerres/orch … at-sav.htm

1) Under Firefox it is correct, except the Javascript menu who arrive under the gallery, why ?
2) Under Opera, yes, all is correctn the JAvascript well arrive above the gallery.
3) The worse as usual is for IE who works strangely.

Why ?
How arrive to have my gallery as for Opera ?

Thanks in advance,
Eric

P.S.: Is is under Windows 7 64bits and the las version of those browers.

Re: Simple Viewer Pro works very differently in differents Browsers

1) & 2) - Please see this FAQ: http://simpleviewer.net/simpleviewer/su … ml#embed_5

3) Differences when viewing a web page in different browsers can often be attributed to HTML errors on the page.
You can validate your page using the W3C Markup Validation Service and then fix any errors found: http://validator.w3.org/
Also, make sure that you have the latest version of Adobe Flash Player installed in Internet Explorer by visiting this page in your browser: http://kb2.adobe.com/cps/155/tn_15507.html

Steven Speirs
SimpleViewer Support Team.

Re: Simple Viewer Pro works very differently in differents Browsers

Hello,

I was waiting for better reply.

My code is valid W3C.

That's sure if i suppress the background that my menu appears...!
I wants to keep the background and have my menu above.

Perhaps z-index muts be use, no ? If you wants help me.
Eric

Re: Simple Viewer Pro works very differently in differents Browsers

Changing your gallery's background to transparent (as described in the FAQ) should fix the problem you are experiencing with your drop-down menu.
If you wish to retain your gallery's background color, you can set it via CSS (for normal mode) and via the 'bgcolor' Flash param (for fullscreen mode).
Try the following embedding code:

<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var params={};
params.bgcolor="222222";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "90%", "100%", 'transparent', true, null, params);
});
</script>

<div id="sv-container" style="background-color: #222222;"></div>

My code is valid W3C.

You had an error on your page when I checked it earlier; a missing </a> tag which you have now fixed.

Perhaps z-index muts be use, no ?

Giving your menu container a high 'z-index' value (such as 'z-index: 99;') might help if your drop-down menu still appears behind the gallery in the Mobile Player.

Steven Speirs
SimpleViewer Support Team.

Re: Simple Viewer Pro works very differently in differents Browsers

Thanks a lot Peter.

Yes, i had a missing </a> at the end of the page, who was outside of the gallery.

I more understand the differents ways to give parameters to Simpleviewer via CSS and via Flash.

Thanks again, that is a good solution.