Topic: Can't embed SimpleViewer in HTML page in Dreamweaver.

OK, I'm sure this solution has been posted somewhere, but i can't find it for the life of me, so i apologize ahead for a "re-post".

Here's the problem:

I have the most basic HTML page that I've made in Dreamweaver.  I bought SimpleViewer Pro and created a standard gallery.  According to the SimpleViewer Support page, to embed my gallery in my HTML page, i need to "Copy the entire contents of your SimpleViewer gallery folder into the folder that contains your HTML page."  (I'm assuming the "gallery" folder is the folder that contains everything: images folder, svcore folder, thumbs folder, gallery xml, and index files).  It then says "In svBuilder, go to the Publish panel and copy the provided Embed Code... Paste the provided code into the body of the HTML page where you want to the gallery to appear." 

OK, so now I've done all of that EXACTLY, and when i preview my page, not a single thing shows up.

My guess would be that I'm doing something wrong with the folders, but i could be completely wrong.

I have my Main Site Folder and inside that is my SimpleViewer folder (which contains images folder, svcore folder, thumbs folder, gallery xml file, and index file).  Does the folder placement seem correct?

Please, any help or light shed on this, will be tremendously appreciated!  Thanks!  big_smile

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

(I'm assuming the "gallery" folder is the folder that contains everything: images folder, svcore folder, thumbs folder, gallery xml, and index files).

That is correct.

I have my Main Site Folder and inside that is my SimpleViewer folder (which contains images folder, svcore folder, thumbs folder, gallery xml file, and index file).  Does the folder placement seem correct?

If the page into which you are embedding SimpleViewer is inside your Main Site Folder, and you have the SimpleViewer gallery files within a subfolder inside your Main Site Folder, then you have two choices:
(1) Move the contents of your SimpleViewer gallery folder into your Main Site Folder
... or:
(2) Use a baseURL within your embedding code to point to the gallery folder, eg:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="simpleviewer_gallery_folder/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars={};
flashvars.baseURL="simpleviewer_gallery_folder/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

If you continue to experience difficulties, please post the URL to your gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

Thanks for the reply!  I got it to work actually, but i did it by importing media... a SWF file.  I dropped the images from the gallery into the images folder i already had in my site, and copied the thumbs folder in there and the gallery.xml file and the simpleviewer.swf file.

It's like this...

MAIN SITE FOLDER:
       - index.html (home page, this is where i want the gallery).
       - gallery.xml
       - simpleviewer.swf
       - Thumbs (folder)
       - Images (folder)

That seems to work.  The gallery actually shows up and works properly.  HOWEVER, i built my gallery to have a white background, but it's not coming up that way.  It comes up with a black background.  I'm guessing this has something to do with the way i did this, or the fact that it's an imported swf?


Onto what you suggested, if i do it that way, my folder situation should look like this?

MAIN SITE FOLDER:
       - index.html (home page, this is where i want the gallery).
       - gallery.xml
       - index.html (created by simpleviewer... needs to be renamed though, correct)
       - svcore (folder)
       - thumbs (folder)
       - images (folder)

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

index.html (created by simpleviewer... needs to be renamed though, correct)

The 'index.html' file created by SimpleViewer is redundant if you are embedding the gallery into another page using the recommended embedding code.
It would only be of use if you wanted to view the gallery on its own or if you wanted to embed the gallery into another page using an <iframe>.
If you like, you can always keep your galleries (including the 'index.html' files) in individual folders and embed them using the baseURL method described here: http://simpleviewer.net/simpleviewer/su … l#external
With regard to your gallery's background color, please post the URL to your gallery and I'll take a look.

Steven Speirs
SimpleViewer Support Team.

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

Here is the gallery... it's live right now.

http://www.myhatdeals.com/

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

Please see this note for 'Embedding Using Dreamweaver' in the 'SimpleViewer Embedding Guide'.
http://simpleviewer.net/simpleviewer/su … reamweaver

Once you have replaced Dreamweaver's embedding code with the recommended embedding code for your gallery, your background color will be correct and your gallery will also work in non-Flash-enabled browsers (which it currently will not).

Steven Speirs
SimpleViewer Support Team.

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

I apologize, but other than way that i've described that worked for me... i'm not understanding.

Re: Can't embed SimpleViewer in HTML page in Dreamweaver.

Nevermind... i figured it out!  Thanks so much for everything Steven, you helped me out tremendously!