Topic: Wordpress gallery styling

Hi there,

I'm using the SV to build galleries--one gallery per page on a wordpress site. Styling the galleries using the "pro options" box (inserting the pro config options such as imageDropShadow="true") following the directions I found isn't working. Even the options I have set in the "edit gallery" settings (such as frame width) aren't working.  After I tried to use the "pro options" box, I got these error messages:

Warning: DOMDocument::load() [domdocument.load]: Specification mandate value for attribute captionText in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/uploads/1.xml, line: 2 in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 676

Warning: DOMDocument::load() [domdocument.load]: attributes construct error in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/uploads/1.xml, line: 2 in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 676

Warning: DOMDocument::load() [domdocument.load]: Couldn't find end of Start Tag simpleviewergallery line 2 in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/uploads/1.xml, line: 2 in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 676

Warning: DOMDocument::load() [domdocument.load]: Extra content at the end of the document in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/uploads/1.xml, line: 2 in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 676

Fatal error: Call to a member function getAttribute() on a non-object in /home/pollym5/public_html/johnorcuttnaturephoto.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 681

What am I doing wrong?  Note: I did not use SV Builder to create these galleries.  I uploaded images into the WP media gallery and I'm trying to style the galleries from there. I did do the pro upgrade to the SV plugin.  Thanks for your help!

pmac

Re: Wordpress gallery styling

It appears that you may have entered a Pro Option incorrectly.
Your XML file (1.xml') contains the entry:

captionText Alignment="left"

... whereas it should be:

captionTextAlignment="left"

... without the space between 'Text' and 'Alignment'.
Try removing the entry from the XML file manually (by opening the file in a plain text editor) and re-add it through the interface (or manually if you like).

Steven Speirs
SimpleViewer Support Team.

Re: Wordpress gallery styling

OK, So in my SV plugin in place, I can no longer "edit gallery" for the gallery with the error message, nor can I delete the gallery (either from the plugin page or the page page).  It's acting really strange.  I'll try to open it in a text editor.  Where do I find that file?

Re: Wordpress gallery styling

The file can be found in the 'wordpress_folder/wp-content/uploads/' folder.
Download the file '1.xml' to your desktop, edit the file in a plain text editor and re-upload it to the same folder, overwriting the existing file.

Steven Speirs
SimpleViewer Support Team.