Topic: Viewing on iPad

I have embedded a Simpleviewer gallery on a wordpress page, and all works well.  (Here's an example: http://laurashoe.com/composites.)   When I created it, I unchecked the box that said "use Flash".  However, it does not display on my iPad.  Instead, it gives me the "Get Adobe Flash" button.

I used the instructions on the site for embedding in Wordpress using the Kimili flash plugin.

Any ideas?  Much appreciated!

Re: Viewing on iPad

The Kimili Flash Plugin has embedded only SimpleViewer's SWF file using <object> tags.
In order for SimpleViewer to fallback to the Mobile Player if the Adobe Flash Player is not detected in the user's browser, the gallery must be embedded using the embedding code found in the SimpleViewer Embedding Guide.
Either use the WP-SimpleViewer WordPress Plugin or create your gallery using svBuilder, upload it to your web server using an FTP program such as Filezilla and embed it in a WordPress post using one of the two methods described here (ensuring that when you enter the embedding code into the body of the post, the method of entry is 'HTML' rather than 'Visual').

Steven Speirs
SimpleViewer Support Team.

Re: Viewing on iPad

Thanks so much for the prompt and thorough reply, Steven.  Works great. 

On another issue, in a regular browser, is there any way to eliminate some of the blank space above the gallery? (example http://laurashoe.com/composites)  On a regular WP page with text, I don't have this issue.

Re: Viewing on iPad

When viewing the gallery with the Flash Player, some of the space above the gallery originates from your WordPress theme and some from SimpleViewer allowing space for the portrait-style images in your gallery.
If you click on image #2 in your gallery, you will see a portrait-style image being displayed and there will be less apparent space above the gallery.
When viewing the gallery with the Mobile Player and images are being displayed (rather than the thumbnail page) all the white space above the gallery is due to the CSS settings of your WordPress page/theme and not the gallery itself.
Is the theme perhaps leaving room for a post's title which you have chosen not to use?
Your theme may have user-changeable settings in the WordPress Dashboard. Have a look to see if there are any spacing settings there.

Steven Speirs
SimpleViewer Support Team.

Re: Viewing on iPad

No, the theme isn't leaving space for a title (I have eliminated the title and space in this and most pages  the custom includes.)  Notice how little space there is on this page:  http://laurashoe.com/private-instruction/


One last question as well ... that's what you get for being a great resource!  ;-)   In the mobile version, the images are being enlarged, so they are not sharp.  Any way to restrict them to their original sizes.

Re: Viewing on iPad

The white space above the gallery from simpleviewer is actually blocking part of my Photo Gallery drop down menu... how much varies.  :-(

Re: Viewing on iPad

I notice that your gallery's embedding code in enclosed in two sets of <p></p> tags and includes two <br /> line breaks which is likely to be causing the white space above the gallery.

<p><!--START SIMPLEVIEWER EMBED.--><br />

<script type="text/javascript" src="http://laurashoe.com/sv_galleries/composites_sv/svcore/js/simpleviewer.js"></script><br />
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://laurashoe.com/sv_galleries/composites_sv";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "ffffff", true, flashvars);
});
</script></p>
<div id="sv-container"></div>
<p><!-- END SIMPLEVIEWER EMBED --></p>

To prevent WordPress from 'formatting' your embedding code, you may need to install and use a plugin such as Raw HTML: http://wordpress.org/extend/plugins/raw-html/

In the mobile version, the images are being enlarged, so they are not sharp.  Any way to restrict them to their original sizes.

No. The only customization options available to the Mobile Player are here: http://simpleviewer.net/simpleviewer/pr … tml#mobile
The best course of action might be to feed SimpleViewer higher quality images.

The white space above the gallery from simpleviewer is actually blocking part of my Photo Gallery drop down menu... how much varies.

Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … ml#embed_5
Essentially, use the following embedding code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://laurashoe.com/sv_galleries/composites_sv/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://laurashoe.com/sv_galleries/composites_sv";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "transparent", true, flashvars);
});
</script>
<div id="sv-container" style="background-color: #ffffff;"></div>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: Viewing on iPad

Steven Speirs wrote:

I notice that your gallery's embedding code in enclosed in two sets of <p></p> tags and includes two <br /> line breaks which is likely to be causing the white space above the gallery.
To prevent WordPress from 'formatting' your embedding code, you may need to install and use a plugin such as Raw HTML: http://wordpress.org/extend/plugins/raw-html/

I used raw-html, and as expected, that got rid of a couple lines of white space, but there is still a huge amount.  If I add text to the top, just to attempt to show what the sv embed is doing, this is what I get: 
http://laurashoe.com/photo-galleries/composites/

Re: Viewing on iPad

If you view a portrait-style image with the Mobile Player (on your iPad or with Flash Player disabled in a browser on your computer), you should see very little space between the text and the gallery showing that the <div> into which the gallery is embedded has very little space around it.

With the Flash Player, you could reduce the space around the elements in the gallery by setting the SimpleViewer Pro option stageBorder="0" (the default value used in SimpleViewer Standard is '10').
Also, you could make the main image completely fill the available image area by setting imageScaleMode="FILL".
SimpleViewer Standard uses imageScaleMode="SCALE", scaling down large images to show the full image and retain the original aspect ratio.
For reference, the SimpleViewer-Pro Config Options can be found here: http://simpleviewer.net/simpleviewer/pr … tions.html

Steven Speirs
SimpleViewer Support Team.