Topic: 'Simpleviewer' is undefined

Just installed to try out - all looks ok in SVBuilder preview but when I embed the html code in webpage and try a view I get the above message.
Is there something else I need to do?
I am using Net Objects Fusion v10 to construct my website.

thanks

Re: 'Simpleviewer' is undefined

Make sure that you have uploaded all the files required for your gallery, including the 'svcore' folder, and that they are all in their correct locations.
If using svBuilder to create your gallery, you can upload the entire gallery folder (not just the contents) to your web server without modifying any filenames or moving any files, and then embed your gallery by using one of the two methods described here: http://simpleviewer.net/simpleviewer/su … l#external
If you continue to experience difficulties, please post the URL to your gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: 'Simpleviewer' is undefined

Hi I am also new to simple viewer and having similar problems. I am using Net Objects essentials. I have created a test gallery which works in my browser. I have uploaded the file to the folder Assets using Filezilla. First problem I cannot get the generated html to embed on the page locally same as the person above. I get the message simpleviewer undefined. Also have I uploaded the SV file to the wrong location? Sorry for being such a dunce. roll

Re: 'Simpleviewer' is undefined

Never did get it to work - gave up and used Flash Slideshow Maker.  Very easy and simple to use, especially in Basic mode.
In Net Objects Fusion you just add the .swf component it creates onto the page.  No need to use Filezilla or put anything onto the server (unless you use the Advanced mode which is not needed most of the time).
Hope this helps.

Re: 'Simpleviewer' is undefined

Thanks gprit.
I am rapidly getting to that point! I will take a look at Flash Slideshow Maker!

Re: 'Simpleviewer' is undefined

I am not familiar with NetObjects Fusion Essentials but looking at the structure of a test project, the following instructions should work for embedding a gallery in a local preview.

(1) Create a new site.
It will be located in a path such as: C:\Program Files (x86)\NetObjects\NetObjects Fusion Essentials\User Sites\site_name\

(2) Copy your entire SimpleViewer gallery folder (not just the contents) to the site's 'Assets' folder:
C:\Program Files (x86)\NetObjects\NetObjects Fusion Essentials\User Sites\site_name\Assets\

(3) Paste the following embedding code where you would like your gallery to appear, changing the gallery dimensions and background color as desired. Also, change the two instances of 'gallery_folder_name' to the actual name of your gallery folder.

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="../Assets/gallery_folder_name/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars={};
flashvars.baseURL="../Assets/gallery_folder_name/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

(4) Click 'Preview Site'. Your gallery should be displayed on your page.

Steven Speirs
SimpleViewer Support Team.

Re: 'Simpleviewer' is undefined

Thank you Steven Spiers!
I have been sidetracked from this probelm for a while, just getting back to it now! I will try what you recommend..

Re: 'Simpleviewer' is undefined

Hmm, okay, when I do this it wont let me add the assest as one complete folder, only as individual files and images which will take forever! Is that what I have to do?

Re: 'Simpleviewer' is undefined

Find the location of the Assets folder on your hard drive and copy the entire gallery folder into Assets folder using Windows Explorer (or Mac equivalent) rather than through the NetObjects Fusion interface.

Steven Speirs
SimpleViewer Support Team.

Re: 'Simpleviewer' is undefined

Thank you Steven, ummm.. I may have more of a problem than I thought.
User sites are all there when viewed in essentials but if I look for them via the hard drive the folder is empty.
So I may be straying too far off a mere simpleviewer problem!

Last edited by Deb D (2012-06-09 17:54:58)

Re: 'Simpleviewer' is undefined

Make sure that you looking in a location such as: C:\Program Files (x86)\NetObjects\NetObjects Fusion Essentials\User Sites\
After creating a new site ('File -> New Site -> Blank Site...'), it should appear as: C:\Program Files (x86)\NetObjects\NetObjects Fusion Essentials\User Sites\site_name\
... with as 'Assets' folder: C:\Program Files (x86)\NetObjects\NetObjects Fusion Essentials\User Sites\site_name\Assets\

When I create a new site in NetObjects Fusion on my PC, neither the new site folder nor the assets folder within it are hidden by default so they should be visible.

Steven Speirs
SimpleViewer Support Team.

Re: 'Simpleviewer' is undefined

Thank you for your patience with me!

Yep, they are not saved there!
I performed a search and they are here:
C:\Users\Debbie\App Data\Local\Virtual Store\Programme Files\Net Objects Fusion Essentials\User Sites\ debbiedunbarcouk

Why, I have no idea, all the back ups are stored in the same location. I can't import the simpleviewer gallery to this location.Is it possible to move them to where they should be?

Debbie

Re: 'Simpleviewer' is undefined

I also created an entirely new site and that has saved to the same place!

Re: 'Simpleviewer' is undefined

Why, I have no idea, all the back ups are stored in the same location.

When I installed Net Objects Fusion Essentials to my PC, the default location for the sites is the path I quoted.
When you select 'File -> New Site -> Blank Site' you are given the choice of where to save the site.
It does not matter where you save the site to, as long as you know where it is.
The SimpleViewer gallery should be copied to the '[path_to_site]/Assets/' folder regardless of where the site is on your hard drive.

I can't import the simpleviewer gallery to this location.

Is this simply because you cannot navigate to this location in Windows Explorer? If so, you will need to show hidden files by going to 'Organize -> Folder and search options ->View (tab)' (in Windows Explorer), select 'Show hidden files, folders. and drives' in the 'Advanced' section and click 'OK'. The 'AppData' folder will now become visible and you should be able to navigate to your 'site' folder.

Steven Speirs
SimpleViewer Support Team.

Re: 'Simpleviewer' is undefined

Hi,
I can find them, they are just defaulting to the virtual store, I have seen this is to do with the UAC
I was being denied access even though I am the only user and the admin on this computer. I have changed the permissions to everyone and have now copied
1) the two websites to the proper location in the user sites so now have two copies one at each location!

2) I have successfully copied the SV gallery as a complete folder to the assets folder at both locations.

Now holding breath to see if I have bu**ered it all up! I will let you know!