Topic: Gallery has black background in IE

I have several galleries running with WP-SimpleViewer at this test site: http://cabanga.kreativation.co.za

I've placed an image, sized exactly the same as the gallery, behind it. This loads a little quicker than the Flash gallery, so it gives users a placeholder image in the few seconds until the gallery itself appears. The galleries have their background set to 'transparent' (both in the WP-SimpleViewer checkbox, and in the Pro options), to allow the placeholder image to show through while the gallery loads.

However, in Internet Explorer (8 and 9, I think in 7 too), the gallery loads with a black (very dark grey) background, blocking the image. In the source, the <object> tag includes:

<param name="wmode" value="transparent"><param name="bgcolor" value="#222222">

It seems IE is overriding the transparency with the bgcolor setting, while other browsers do the opposite.

I've checked the settings in the 'Edit Gallery' section in Wordpress, and there's no reference to #222222 anywhere. Furthermore, when I specify a background colour of #ffffff, after saving the gallery that field appears empty.

I've seen a couple of posts here referring to editing the embed code for an iframe, or the flashvars, but I don't see how any of that is accessible when running the gallery through the Wordpress plugin.

How can I get rid of that black background in IE?

Re: Gallery has black background in IE

In IE, try going to 'Tools -> Internet options -> Advanced -> Accelerated graphics' and select the 'Use software rendering instead of GPU rendering' checkbox. Then click 'OK', close IE and restart your browser.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery has black background in IE

Thanks, that works.

Is there no way to get around the problem from the server side? If that checkbox is unticked by default, most users won't see the page the way they should.

Re: Gallery has black background in IE

Is there no way to get around the problem from the server side?

Not that I know of.

If that checkbox is unticked by default, most users won't see the page the way they should.

It might be reassuring to know that the checkbox is unselected on my PC and the gallery's background is transparent as it should be (rather than black), so other users may see the gallery as intended.
Check that you have the most recent drivers installed for your graphics card and the most recent version of Adobe Flash Player installed.

Steven Speirs
SimpleViewer Support Team.

Re: Gallery has black background in IE

Thanks for the help. Glad to hear it's not necessarily the default setting.
In any case, I've optimised the images and improved the loading time enough that the issue is now minor enough to have passed the client's approval.