Topic: Gallery XML not found

Hi,

I am not sure what version of simple viewer I am using but since I implemented this more than a year ago I am guessing it's version 1.

I get the gallery xml not found error when viewing the gallery from a pc but when visited from an android phone it works perfectly, any help?

Re: Gallery XML not found

I have now made a new gallery with the current simpleviewer, but I still have the same issue.

Re: Gallery XML not found

Please post the URL to the gallery so that we can take a look.
In the meantime, please see this FAQ regarding the 'Gallery XML Not Found.' message: http://simpleviewer.net/simpleviewer/su … #trouble_6

Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML not found

Hi,

The link is http://www.africarest.co.za/Gallery/

The faq says that the xml file should be in the gallery folder where should the gallery folder be placed?

Re: Gallery XML not found

If following the embedding instructions here: http://simpleviewer.net/simpleviewer/su … html#embed
... then all the contents of the gallery folder should be in the same directory as the HTML document into which the gallery is being embedded.
Your gallery's XML file looks to be in the correct location and your gallery is displayed OK by the Mobile Player but not by the Flash Player, which displays the 'Gallery XML Not Found' message.
Try using a relative path to the 'simpleviewer.js' file. You could also try explicitly specifying the path to the 'gallery.xml' file via the galleryURL option.
If implementing both of the above suggestions at once, then your embedding code would become:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars={};
flashvars.galleryURL="gallery.xml";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "transparent", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->
Steven Speirs
SimpleViewer Support Team.

Re: Gallery XML not found

Hi I have made the path relative and added the explicit path to gallery.xml

Now chrome gives the following error:  Uncaught TypeError: Object #<Object> has no method 'jQuery'

Re: Gallery XML not found

Hi,


The problem was that the html page base was referring to the old location of the site,

After removing the base tag from the header everything is working fine.

Thank you for your help, I am very impressed with the support

Kind Regards

Re: Gallery XML not found

I'm glad you have sorted out your problem. Thank you for posting back to let us know.

Steven Speirs
SimpleViewer Support Team.