Topic: fatal error message

I entered pro options into the "pro options" box and got this fatal error message. I am using the wordpress plugin with the pro upgrade.  I've had this problem before so I'm trying to search for my own post here in the forum.  Here is the message:Warning: DOMDocument::load() [domdocument.load]: Specification mandate value for attribute CaptionBack in /home/pollym5/public_html/judyscolors.com/wp-content/uploads/8.xml, line: 2 in /home/pollym5/public_html/judyscolors.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 795

Warning: DOMDocument::load() [domdocument.load]: attributes construct error in /home/pollym5/public_html/judyscolors.com/wp-content/uploads/8.xml, line: 2 in /home/pollym5/public_html/judyscolors.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 795

Warning: DOMDocument::load() [domdocument.load]: Couldn't find end of Start Tag simpleviewergallery line 2 in /home/pollym5/public_html/judyscolors.com/wp-content/uploads/8.xml, line: 2 in /home/pollym5/public_html/judyscolors.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 795

Warning: DOMDocument::load() [domdocument.load]: Extra content at the end of the document in /home/pollym5/public_html/judyscolors.com/wp-content/uploads/8.xml, line: 2 in /home/pollym5/public_html/judyscolors.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 795

Fatal error: Call to a member function getAttribute() on a non-object in /home/pollym5/public_html/judyscolors.com/wp-content/plugins/wp-simpleviewer/wp-simpleviewer.php on line 800

Re: fatal error message

It looks like you may have entered:

CaptionBackColor="ffffff"

... note the uppercase 'C' at the beginning of the line.

The option should start with a lowercase 'c':

captionBackColor="ffffff"

You may have to manually edit the XML file to remove the CaptionBackColor option first before entering the correct option in the Pro Options text area.

Steven Speirs
SimpleViewer Support Team.

Re: fatal error message

OK so I fixed the fatal error message and the gallery is back.  This is what I added to the pro options:
captionPosition="BOTTOM"
captionFontColor="000000"
CaptionBackColor="ffffff"

I would like the caption below the image and obviously, simple black font on a white background, but it isn't there.  Do I need a # in front of the color?  I also tried changing the "text color" to 000000in the standard options...

Re: fatal error message

K, saw the "C" in the third style, fixed it, and there is still no caption appearing.  I tried to manually update as well.

Re: fatal error message

Add floatCaption="FALSE" to your Pro Options in order for the caption height to be counted in stage layouts.
You might also like to set the captionHeight as the default value of 120 may be a little too large for your single line captions.
Try captionHeight="40".
The full range of available Caption Options can be found here: http://simpleviewer.net/simpleviewer/pr … ml#caption

Steven Speirs
SimpleViewer Support Team.

Re: fatal error message

Great!  Thanks!