Topic: Remove featured image from showing in gallery??

I'm using featured images in my wordpress posts (for banner images). The problem is they show up in the simpleviewer gallery on the page. Is there some way to exclude this image from the simpleviewer gallery?

Re: Remove featured image from showing in gallery??

If you do not intend to edit the gallery (in which case it will likely be re-added to the gallery) you could remove teh image from the gallery by removing the corresponding <image> entry from the gallery's XML file.
The gallery's XML file will be named 'gallery_id.xml' and will be located in the 'wp-content/uploads/' folder.
Download the file via FTP, edit the file in a plain text editor (removing the relevant <image entry) and re-upload the file to the original location.

Steven Speirs
SimpleViewer Support Team.

Re: Remove featured image from showing in gallery??

Thanks for the answer. This website is for a client so that's not a great solution. One of the main reasons I wanted to use this for their site is that it's extremely easy for them to add images to the gallery on the page by simply uploading images to the page.

After testing a few things I found a 'solution' ..maybe this will help somebody else with the same question:

Instead of setting the featured image by clicking "set featured image > upload from computer" you should instead first upload the image to the media library. Then back on the page click "set featured image > media library". By doing that the featured image doesn't get added to the gallery.

Re: Remove featured image from showing in gallery??

I'm glad you have found a workaround. Thank you for sharing your tip.

Steven Speirs
SimpleViewer Support Team.