Topic: Report bugs for pro 2.2

1. Background color setting cannot be saved. It will always blank.

2. If I replace Flicker username (put in blank) with flickrUserId="example@??" in the pro option, the whole gallery set thumbnails are displayed. Its main image and navigation will missing.

Last edited by nkkhoo (2011-10-29 21:13:23)

Re: Report bugs for pro 2.2

1. Background color setting cannot be saved. It will always blank.

Please state the program to which you are referring (svBuilder-Pro, Photoshop Template, Picasa Template, svManager, etc).

2. If I replace Flicker username (put in blank) with flickrUserId="example@??" in the pro option, the whole gallery set thumbnails are displayed. Its main image and navigation will missing.

This sounds like you are describing the Mobile Player (rather than the Flash Player).
Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … trouble_14
Make sure that the useFlash Embed Code Parameter in your embedding code is set to 'true' and that you have Adobe Flash Player installed and enabled in your browser.

Steven Speirs
SimpleViewer Support Team.

Re: Report bugs for pro 2.2

1. This support forum is specified for SimpleViewer-Pro v2, therefor my bug is found in  SimpleViewer Pro 2.2.

2. My desktop browser runs the latest Adobe Flash player and useFlash was ticked.

Why not you run the same settings from your PC first to see same problem or not instead of making your "sounds like" assumption.

Re: Report bugs for pro 2.2

1. This support forum is specified for SimpleViewer-Pro v2, therefor my bug is found in  SimpleViewer Pro 2.2.

SimpleViewer is the name given to the gallery itself.
A SimpleViewer gallery can be created by a number of different programs: http://simpleviewer.net/simpleviewer/pr … #templates
Each of these programs may have an interface in which the background color is entered by the user and may or may not be saved for future use.
I do not know to which program you are referring but, having tried settting a background color in svBuilder-Pro, the program set the correct background color (the Embed Code Parameter in the embedding code generated was not blank) and on opening the gallery to edit it, the correct background color was determined and displayed in the live preview window.

2. My desktop browser runs the latest Adobe Flash player and useFlash was ticked.

Please post the URL to your gallery so that I can take a look and hopefully help further.

Why not you run the same settings from your PC first to see same problem or not instead of making your "sounds like" assumption.

I did and cannot reproduce either of your problems, hence my requests for more information and suggestions in case they were helpful to you.

Steven Speirs
SimpleViewer Support Team.

Re: Report bugs for pro 2.2

1. I am using a plugin version download from the wordpress.org and all gallery settings are done from my browser.

2. I have to re-set the option to simulate the result, will post the URL later.

=>Latest update, reset by using flickrUserId option, but fail to see the same result I saw yesterday.

Last edited by nkkhoo (2011-10-30 17:23:19)

Re: Report bugs for pro 2.2

I am using a plugin version download from the wordpress.org and all gallery settings are done from my browser.

Are you using WP-SimpleViewer v2.2.0 downloaded from here: htp://wordpress.org/extend/plugins/wp-simpleviewer/ ?
If so, WP-SimpleViewer does not save the options from the last gallery you created and there is no option within the interface to change the default settings.

1. Background color setting cannot be saved. It will always blank.

The default value for the gallery's background color in WP-SimpleViewer is 'ffffff' and the 'Background Color' text field should display this. It should not be blank.
The default value for 'Background Color' is stored (and can be changed) in line 227 of WP-SimpleViewer's 'config.php' file.

2. I have to re-set the option to simulate the result, will post the URL later.

=>Latest update, reset by using flickrUserId option, but fail to see the same result I saw yesterday.

I am glad to hear that this problem now seems to have been resolved.

Steven Speirs
SimpleViewer Support Team.

Re: Report bugs for pro 2.2

The default value for the gallery's background color in WP-SimpleViewer is 'ffffff' and the 'Background Color' text field should display this. It should not be blank.
The default value for 'Background Color' is stored (and can be changed) in line 227 of WP-SimpleViewer's 'config.php' file.

The default value in my plugin is blank.

Re: Report bugs for pro 2.2

The default value in my plugin is blank.

Are any of the other text fields blank (such as 'Text Color' or 'Frame Color' whose default values are also 'ffffff')?
Is the default value for 'Background Color' (in line 227 of WP-SimpleViewer's 'config.php' file) 'ffffff' or blank?
If blank, change the line to the following:

<input type="text" id="backgroundColor" name="backgroundColor" value="ffffff" />

Otherwise, try reinstalling the plugin following these instructions:
(1) Deactivate WP-SimpleViewer from the Plugins page in the WordPress Dashboard
(2) Delete the 'wp-content/plugins/wp-simpleviewer/' folder
(3) Download the latest version of WP-SimpleViewer from this page: http://simpleviewer.net/simpleviewer/su … pleviewer/
(4) Reinstall and reactivate WP-SimpleViewer following the instructions here: http://simpleviewer.net/simpleviewer/su … r/#install

If this still does not solve the problem, then you could make sure that your WordPress installation is up-to-date (v3.2.1) and you could try temporarily disabling all other plugins and themes to make sure that nothing is interfering with WP-SimpleViewer.
If this works OK, then you could re-enable your installed plugins one by one until you find the one that is causing the problem.

Steven Speirs
SimpleViewer Support Team.

Re: Report bugs for pro 2.2

My mistake, I looked at the edited gallery in which blank field in background color is displayed.

I rechecked the php coding, it's correct with "ffffff". The issue is resolved. Thank.

Other question, if I choose transparent, the background color is overrode by the transparent setting?

Last edited by nkkhoo (2011-10-31 22:08:09)

Re: Report bugs for pro 2.2

Other question, if I choose transparent, the background color is overrode by the transparent setting?

Yes. If you select the 'Background Transparent' checkbox, the 'Background Color' will not be used.

Steven Speirs
SimpleViewer Support Team.