Topic: 'View in browser' fine but not when public

Can anyone help?

The first time i used simpleviewer it worked fine, i then tried to add some photos to the gallery after which it has all gone wrong.  After i  added the new pictures and saved into the original folder the 'view in browser' popped up and it looked fine.  I checked by opening the htm file in my local folder, however this didn't show the main picture as 480px wide by whatever, it showed it as 1px.  Just 1px with a 4px border.  I then uploaded everything using the server, as i was hoping this would be something easy to correct once i had gone public.  Unfortunately it still refuses to work.  http://nostellpriorycarpsyndicate.co.uk/gallery.htm  I have reloaded it, deleted it and started again, but nothing corrects it.  I can't seem to see the new gallery, only the older one.  Even after i deleted everything and started again, when prompted to save, i got a warning telling me that files already existed and do i want to copy over them.  I did but still no joy.  I right clicked on the gallery and took a look at the settings where a  pop up appeared from adobe flash security, saying
"adobe flash player has stopped a potentially unsafe operation. The  following local application on your computer or network:  ...\simpleviewer.swf is trying to communicate with this internet-enabled location ...\gallery.htm.  to let this application communicate with the internet, click settings.  you must restart the application after changing your settings."
What should i change and how do i restart the application?
Has anyone come across this that can help me out.  I would be most grateful.  Its getting late, i've been here 4 hours, my shoulders ache, i've had enough.  anyone? please!

Last edited by shmooveoperator (2011-11-08 00:13:14)

Re: 'View in browser' fine but not when public

Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … ml#embed_7
(Your gallery displays fine in IE9 on my PC.)

Steven Speirs
SimpleViewer Support Team.

Re: 'View in browser' fine but not when public

I have just checked my css against that of the index.html and they are identical.   Which they shouldn't be?

Re: 'View in browser' fine but not when public

You should check the CSS of the page into which the gallery is embedded (http://nostellpriorycarpsyndicate.co.uk/gallery.htm), not the 'index.html' file within the gallery folder which, in your case, is not used.
Your gallery's container (the 'sv-container' <div>) is inside your 'wrapper' and 'content' <div>s, neither of which has been assigned a height vis CSS.

Steven Speirs
SimpleViewer Support Team.

Re: 'View in browser' fine but not when public

So let me get this right, i need to look at my own css page, and set the heights of the wrapper and content divs to 100% and this should do it?

Thank you i'm straight onto it.

Re: 'View in browser' fine but not when public

Here is what i've done

#wrapper {
    width: 900px;
    height: 100%;
    font-size: 28px;
    padding-left: 30px;
    padding-right: 30px;
    margin-left: auto;
    margin-right:auto;
    font-family:Arial, Helvetica, sans-serif;
    list-style-type: none;
    }
#content {
    width: 645px;
    height: 100%;
    font-size: 80%;
    float:left;
    margin-left: 0px;
    padding-left: 25px;
}

Is this what you mean, forgive me for being useless, i don't do this for a living, I did a course just so i could do the site for my local club.

Re: 'View in browser' fine but not when public

The heights you use for the divs in your page will depend on the contents of the page and, in particular, the contents of the divs whose heights you are defining.
Using 100% for both of your parent containers may not be the best solution, especially if either of them contain more that just the gallery itself.
Looking at your page, setting the 'wrapper' height to 100% should be OK but it might be better to set the 'content' height to a fixed setting of, say 600px.
Try changing these values and see how your page's layout changes.
Be sure to clear your browser's cache before reloading the gallery in order to see the changes made.
Please note that you may also need to add the following code to your CSS:

body, html {
    height: 100%;
}
Steven Speirs
SimpleViewer Support Team.

Re: 'View in browser' fine but not when public

Steve you are a genius, if you ever want anything that i can do (within reason) i'll do it.  You have made my month, its a great feeling having someone there that actually wants to help someone.  I wish you and your family the best christmas ever.

Kindest regards

James