Topic: autoPlay not working

I do not know what is wrong but autoPlay does not start for me. It does not matter how often I press space bar autoPlay does not start.

here are my settings. What is wrong? I also do not see any autoplay button.

<simpleviewergallery

        galleryStyle="MODERN"
        title="Johanna"
        textColor="FFFFFF"
        frameColor="FFFFFF"
        frameWidth="1"
        thumbPosition="LEFT"
        thumbColumns="3"
        thumbRows="8"
        showOpenButton="TRUE"
        showFullscreenButton="TRUE"
        showAutoPlayButton="TRUE"
        maxImageWidth="1280"
        maxImageHeight="1280"
        useFlickr="false"
        flickrUserName=""
        flickrTags=""
        languageCode="AUTO"
        languageList=""
        imagePath="images/"
        thumbPath="thumbs/"
>

Re: autoPlay not working

I do not know what is wrong but autoPlay does not start for me.

If you wish the gallery to start autoplaying as soon as it is displayed, use the option autoPlayOnLoad="TRUE" in your gallery's XML file.

It does not matter how often I press space bar autoPlay does not start.

You may need to click somewhere on the Flash stage first to give it focus in order for keyboard shortcuts to work.

I also do not see any autoplay button.

With the options you have used, your AutoPlay button should be positioned in the Button Bar at the top-right hand corner of the gallery between the 'Open Image' button and the 'Full Screen' button.

Steven Speirs
SimpleViewer Support Team.

Re: autoPlay not working

Sorry for the disturbance. There were some settings that prevented a real reloading of the configuration although I pressed F5 in the browser. Now everything works.

Re: autoPlay not working

I'm not getting autoplay to work, either.  The first image shows up and stays there.

    useFlickr="false"
    resizeOnImport="true"
    cropToFit="false"
    galleryWidth="100%"
    backgroundTransparent="true"
    thumbPosition="NONE"
    stageBorder="0"
    stageHPadding="0"
    stageVPadding="0"
    enableLooping="true"
    enableKeyboardControls="false"
    imageFrameStyle="NONE"
    imageClickMode="NONE"
    imageScaleMode="FILL"
    imageTransitionType="CROSS_FADE"
    showAudioButton="true"
    showToolTips="false"
    buttonBarPosition="NONE"
    mobileShowNav="false"
    mobileShowCaption="false"
    mobileShowThumbs="false"
    mobileShowPageCount="false"
    indexPageName="index.php"
    showFullscreenButton="false"
    showOpenButton="false"
    showOverlay="NEVER"
    showImageNav="NEVER"
    titlePosition="NONE"
    captionPosition="NONE"
    autoPlayOnLoad="true"
    displayTime="4"
    audioURL="music.mp3"
    imageTransitionTime="2"
    flashBrightness="2"

Re: autoPlay not working

@billwill
Using your options in a test gallery, the AutoPlay function works fine.
Make sure your gallery uses the SimpleViewer-Pro 'svcore' folder (rather than the SimpleViewer-Standard version) as the AutoPlay options are Pro-only.
If you continue to experience difficulties, please post the URL to your gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: autoPlay not working

hello steven -

Thanks for the additional info to help me troubleshoot this.

I had tried the free version, but uninstalled it after I purchased and installed pro. Based on your reply,  I uninstalled and reinstalled pro, and recreated the gallery.  It works now.

thanks!