Topic: IE8 not finding images

I am embedding a Simpleviewer-pro gallery in an html page and using the following code:

<script type="text/javascript" src="Flash_Galleries/AFsv_gallery/svcore/js/simpleviewer.js"></script> <script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "Flash_Galleries/AFsv_gallery/";
flashvars.galleryURL = "gallery.xml";
simpleviewer.ready(function () {
    simpleviewer.load("sv-container", "95%", "95%", "transparent", true,flashvars, null, null, false);
<div id="sv-container"></div>

The html page can be viewed at: … _Test.html

It works fine in Firefox, Safari, and Chrome. However, in IE8 I get the following message "No Images Specified in Gallery XML".
I have also tested when the html page is in the gallery folder (no path issues), but still get the same message in IE8. I'm a bit of a loss as where to start.
Any suggestions?


Re: IE8 not finding images

Your gallery's XML file has opening and closing tags of <gallery> and </gallery>.
Try changing these to <simpleviewergallery> and </simpleviewergallery> respectively.
Also, if your gallery's XML file is named 'gallery.xml' and is located inside the folder specified by the baseURL, then you can safely remove the galleryURL line from your embedding code.

Steven Speirs
SimpleViewer Support Team.

Re: IE8 not finding images

Thank you very much. That did get rid of the error message. However, the gallery does not display in IE8. All I see is white background in the content area. The content area shown is the same size as shown in the other browsers which display the flash gallery.
I checked the IE8 add-ons and shockwave is enabled.
Any suggests will be greatly appreciated.

Ok no worries, not sure why it is working now, but I downloaded Adobe Flash again and that seemed to take care of it.

Again, thanks for your help.

John --- another non-IE user (in fact it is hidden so I have to use Dreamweaver to launch it)

Last edited by (2011-11-23 05:37:50)