Topic: embed simpleviewer in pdf

I can't manage to embed the simple viewer flash in a pdf file, it always says "gallery not found"...


any ideas?

thanks!

Re: embed simpleviewer in pdf

Try the following as a basic example:
(1) Create a gallery with svBuilder-Pro
(2) Drag and drop the 'simpleviewer.swf' file from your gallery's 'svcore/swf/' folder into Adobe Acrobat
(3) Select the 'Show Advanced Options' checkbox in the 'Insert SWF' window
(4) Click on the 'Resources' tab
(5) Click the 'Add...' button and add your gallery's 'gallery.xml' file
(6) Click the 'Add Directory...' button and add your gallery's 'images' folder
(7) Click the 'Add Directory...' button and add your gallery's 'thumbs' folder
(8) Click the 'OK' button
(9) Go to 'File -> Save As... -> PDF...' and save your PDF file

Steven Speirs
SimpleViewer Support Team.

Re: embed simpleviewer in pdf

that did it, thanks a lot!!

Re: embed simpleviewer in pdf

There was a question below that you have answered, I am having the same problem but with no avail. I noticed you stated svBuilder-Pro in you answer. Do I need this to be able to embed a flash/swf into a pdf?

I can't manage to embed the simple viewer flash in a pdf file, it always says "gallery not found"...

Try the following as a basic example:
(1) Create a gallery with svBuilder-Pro
(2) Drag and drop the 'simpleviewer.swf' file from your gallery's 'svcore/swf/' folder into Adobe Acrobat
(3) Select the 'Show Advanced Options' checkbox in the 'Insert SWF' window
(4) Click on the 'Resources' tab
(5) Click the 'Add...' button and add your gallery's 'gallery.xml' file
(6) Click the 'Add Directory...' button and add your gallery's 'images' folder
(7) Click the 'Add Directory...' button and add your gallery's 'thumbs' folder
(8) Click the 'OK' button
(9) Go to 'File -> Save As... -> PDF...' and save your PDF file

Re: embed simpleviewer in pdf

The method I posted should work with both SimpleViewer-Standard and SimpleViewer-Pro.
I mentioned svBuilder-Pro simply because the original poster posted the thread in the SimpleViewer-Pro v2 forum.

I tested the method myself before posting so it does work.

it always says "gallery not found"...

Have you renamed or moved your gallery's XML file?
The method requires that a gallery's structure be unchanged from being produced by svBuilder/svBuilder-Pro (ie. no galleryURL or baseURL should be used).

Steven Speirs
SimpleViewer Support Team.