Topic: Issue adding a Gallery to a Post using the SimpleViewer WP-Plugin

Hi all,

I've recently updated my wordpress plugin to version 2.2.0.

I wonder if anyone had the same issue that I am seeing when I want to add a simpleviewer gallery to a wordpress post. After pressing the "eye" symbol the Add SimpleViewer Gallery dialog appears. When I press the "Add Gallery" Button, the following error is shown in the editor (where /.../ stands for my servers path)
[simpleviewer
Fatal error: Cannot redeclare class Page in /.../wp-content/plugins/wp-simpleviewer/buildgallery.php on line 1153
]

Anyone's able to help?

Thanks
Stefan

Re: Issue adding a Gallery to a Post using the SimpleViewer WP-Plugin

As far as I can remember I have not seen this error reported before (and a search of the forum returns no hits).
However, I would recommend the following:
(1) Make sure that all the requirements for WP-SimpleViewer are met: http://simpleviewer.net/simpleviewer/su … iewer/#req
(2) Try deactivating and deleting WP-SimpleViewer and download, install and activate WP-SimpleViewer from scratch following these instructions: http://simpleviewer.net/simpleviewer/su … r/#install

Steven Speirs
SimpleViewer Support Team.

Re: Issue adding a Gallery to a Post using the SimpleViewer WP-Plugin

Hi Steven,

thanks for your advice, but unfortunately a re-install of the plugin didn't work. It's even giving me the error message when trying to edit an existing gallery. I thought it might have to do with file / directory permissions, but I also tried setting the permissions to 777 for the plugin itself and its subfolders. But that didn't work either.

Any other suggestions or ideas would be really appreciated.

Thanks
Stefan

Re: Issue adding a Gallery to a Post using the SimpleViewer WP-Plugin

If you are not already using the most recent version of WordPress, try upgrading to v3.3.1.

If this does not help, try temporarily deactivating all other plugins and see if WP-SimpleViewer then works.
If is does, then reactivate your plugins one-by-one until you find the plugin which is incompatible with WP-SimpleViewer.
A list of plugins which are known to be incompatible with WP-SimpleViewer can be found here: http://www.simpleviewer.net/simpleviewe … iewer/#req

This WordPress forum thread (though old) may also be of use with a couple of suggestions to try: http://wordpress.org/support/topic/fata … ass-pclzip

Steven Speirs
SimpleViewer Support Team.

Re: Issue adding a Gallery to a Post using the SimpleViewer WP-Plugin

I could find out that FlickrManager Wordpress Plugin is causing issues: http://wordpress.org/extend/plugins/wor … r-manager/

It might be because it's using the jQuery Lightbox. Unfortunately deactivating Lightbox for the FlickrManager doesn't help, while completely deactivating FlickrManager does. However that's no option for me since I am heavily using FlickrManager on my website.

What I found out is that the simpleview galleries will actually work once I was able to create them and add them to a blogpost.

So as a workaround I can deactivate FlickrManager -> create / modify / add a gallery -> activate Flickr Manager again.
Well it's not good but it works for me, since I hardly ever change my simpleviewer galleries due to its capability of dynamically pull images from  flickr gallery.

I am wondering why simpleviewer plugin doesn't have issues with showing the webgallery with FlickrManage (jQuery Lightbox) activated and it has only issues with modifying / adding galleries to a post.

Thanks for all your help Steven.

Re: Issue adding a Gallery to a Post using the SimpleViewer WP-Plugin

Another workaround which would enable you to include a SimpleViewer gallery in a WordPress post (other than to use WP-SimpleViewer) would be to:
(1) Create your gallery using svBuilder-Pro or any other method of your choice.
(2) Upload the entire gallery folder (not just the contents) to your web server using an FTP program such as Filezilla.
(3) Embed the gallery into a WordPress post using one of the two methods described here, ensuring that, when entering the embedding code into the body of the post, the method of entry is 'HTML' rather than 'Visual'.

Steven Speirs
SimpleViewer Support Team.