Topic: Images gone from 'image folder' after SimpleViewer Pro V2 upload crash

Hi

Really odd, I went to change a gallery with 222 images in it which was already live and working fine I just wanted 'auto play on' so I opened the gallery all images load. Went to customise, select 'autoplay on' then save in it's current location. I realise it's actually crashed when it's taken ages to show me the local gallery. So I have to force quit it. I try again, select the gallery but no images show, in fact it goes back to the open/create new page. I try this a few times and then with another small gallery which loads fin. I then go to the folder where the on my idisk where the gallery lives and to my shock there are now only 22 images in the 'image folder' and all 222 thumbs in the 'thumbs' folder.!?!?!? I definitely didn't go in the folder and delete the images myself... And I checked my trash and searched my files to see if they have jumped to a new location somehow... Any ideas how what has happened here?

Cheers for reading!

Tamsin

Re: Images gone from 'image folder' after SimpleViewer Pro V2 upload crash

I just wanted 'auto play on'

One way to do this would have been to edit the gallery's XML file in a plain text editor and add the option autoPlayOnLoad="TRUE".

I then go to the folder where the on my idisk where the gallery lives and to my shock there are now only 22 images in the 'image folder' and all 222 thumbs in the 'thumbs' folder.!?!?!?

svBuilder can not build or edit a gallery online and does not have built-in FTP functionality so if images have been deleted from your online iDisk folder, then it cannot have been done by svBuilder.
Check the settings of the program that you use to upload your gallery files.

Steven Speirs
SimpleViewer Support Team.

Re: Images gone from 'image folder' after SimpleViewer Pro V2 upload crash

Hi Steven

Cheers for that tip... Not a codey person myself but I'll look for that in the code on the XML file next time I need a small change.

So even when the SV Builder is rebuilding the gallery files it's not possible in the overwriting process when it 'crashed' that it overwrote the existing files and didn't finish, thus leaving only a few of the images required for the gallery?

PS I've found SV Builder is crashing a lot recently with other galleries too even with no other applications running... Is there a way sending crash reports?

Tamsin

Re: Images gone from 'image folder' after SimpleViewer Pro V2 upload crash

So even when the SV Builder is rebuilding the gallery files it's not possible in the overwriting process when it 'crashed' that it overwrote the existing files and didn't finish, thus leaving only a few of the images required for the gallery?

It is possible that if the program crashed, your local gallery folder (on your computer's hard drive) would be incomplete but svBuilder does not have access to files stored online in your iDisk account so cannot have deleted those.
I do not know how you are uploading the gallery folder but perhaps the program you use is deleting the existing (complete) gallery folder online first before replacing it with the (incomplete) gallery folder.

PS I've found SV Builder is crashing a lot recently with other galleries too even with no other applications running... Is there a way sending crash reports?

What exactly happens when svBuilder crashes? Does it freeze, close automatically or display an error message (or something else)? At what point does it happen? Is there any sequence of events that I can follow to replicate the problem?

Try the following and make sure that you have the latest versions of the installation files for both Adobe Air (v3.1) and svBuilder (v2.2.0) before proceeding.
The latest version of Adobe Air can be downloaded from this page: http://get.adobe.com/air/
Please see this page regarding Upgrading SimpleViewer and svBuilder: http://simpleviewer.net/simpleviewer/su … grade.html

(1) Uninstall svBuilder
(2) Uninstall Adobe Air
(3) Delete this folder:
Mac: /Users/your_username/Library/Application Support/Adobe/AIR/svBuilder
(4) Install Adobe Air v3.1
(5) Install svBuilder v2.2.0

Adobe's 'Troubleshoot Air Installation' pages may also be of help.
Mac: http://kb2.adobe.com/cps/902/cpsid_90205.html

Steven Speirs
SimpleViewer Support Team.

Re: Images gone from 'image folder' after SimpleViewer Pro V2 upload crash

Hi Steve

Ahhh ok it is possible then that the images have been overwritten and deleted as I upload and create the gallery folder from SVB direct to my idisk! I should create it locally then upload it you would recommend? Just seemed to be simpler to create it directly and not so long.

I will try your suggestions for the crashing tomorrow, the problem seems to be mainly when I come to save and sometimes when I'm loading new images... The saving maybe because it's going to the idisk... I'll test this with a large gallery first I think. And of course check everything is up to date... it should be though as I have an update manager.

Thanks for you assistance again!

Tamsin

Re: Images gone from 'image folder' after SimpleViewer Pro V2 upload crash

I should create it locally then upload it you would recommend?

It would probably safer to do it this way as you would have complete control over the whole process and the local copy would serve as a backup.

Steven Speirs
SimpleViewer Support Team.