Topic: issue with background image

Hey,

for background color settings (without background image), the embeding works quite well:
http://hella-stroh.de/weblog/galerie/so … tagsdesign
The background of the embeding page shines through, and when going to fullscreen mode, the set background color is displayed. So far, so good.

But we have the following problem with the option "background image" in SimpleViewer Pro:

In svManager, the following settings are made:
- backgnd transparent is checked
- background image is filled (file is positioned on the server)

My understanding of these settings is, that when I embed the gallery into a WordPress post, the background of the WordPress post should appear, and when I go to fullscreen mode, the background image of the SimpleViewer Gallery is loaded, similar to the variant without background image. But this does't work as expected, the background image is not only visible in fullscreen mode, but also on the page, where the gallery is embeded.

Why?

The reason for our question is, that we want to show a homogenous appearance:
The basic home page of the site concerned looks like this: http://www.dat-ei.de
(It's a SimpleViewer gallery embeded as simple slideshow without interaction possibilities), this is an example, how we want the fullscreen background look like.

The gallery embeded in a WordPress post should look like this: http://www.dat-ei.de/weblog/allgemein/d … ialzundung

But when we add a background image to the gallery and set background transparent to "true", the embedded gallery nevertheless shows the background image: http://www.dat-ei.de/weblog/allgemein/d … zundung-v2.
In addition, the display options cannot be set to "tile", so that in fullscreen mode the background image doesn't show correctly.

Any idea how to solve the problem?

Regards, Hella

Last edited by come_paglia (2012-01-22 12:07:34)

Re: issue with background image

But this does't work as expected, the background image is not only visible in fullscreen mode, but also on the page, where the gallery is embeded.

If a backgroundURL is set, then this background will be used in both normal and fullscreen modes (whether or not the backgroundColor Embed Code Parameter is set to 'transparent). The backgroundURL option takes precedence over the backgroundColor parameter.
If you want the gallery's background to be transparent in normal mode (to allow an HTML/CSS background to shine through) but to use a specific image in fullscreen mode, you would have to embed SimpleViewer-Pro into a container movie using Adobe Flash, add an event listener to the FullScreenEvent.FULL_SCREEN event to call a function which will load the gallery using a different set of Embed Code Parameters and a different set of options (a backgroundURL).
The information and codes in these threads may help if you decide to go down this route:
http://www.simpleviewer.net/forum/viewt … p?id=13209
http://www.simpleviewer.net/forum/viewt … p?id=13224

Steven Speirs
SimpleViewer Support Team.