Topic: mobile thumbs inactive with linked css

I am stumped as to why my mobile gallery works fine when page css is used inline (on the html page) and is inaccessible if I use the same css, just linked.

When I say the mobile gallery is inaccessible I mean that the grid of thumbs load, but they are not active links (cursor stays as cursor, no link hand). Clicking or tapping anywhere on the grid does not work. I have tried this in both desktop browsers (firefox, safari, chrome) with flash disabled and mobile device(ios5). Same result (I am using a mac, have yet to boot windows).

Galleries are simpleviewerPro 2.2.0 clones.

Here are two identical html pages except the css is inline on one and linked on the other.

css inline in html -->     http://www.arch-clig.com/test/construct … index.html

linked to sitecss.css --> http://www.arch-clig.com/test/construct … index.html

I could just use the inline css everywhere and move on, aside from being perplexed I would like to centralize the css.

Any help most appreciated.

Re: mobile thumbs inactive with linked css

Try increasing the 'z-index' value for your 'flashcontent' <div> to see if this makes a difference.

Steven Speirs
SimpleViewer Support Team.

Re: mobile thumbs inactive with linked css

Oh for heavens sake!

Linked css doc had 'flashcontent' <div> at z-index: -1, while inline was z-index: 1.
Setting z-index on linked css to '1' seems to resolve problem. All good now (on mac and ios, still to test windows).

I could have sworn the 2 css texts were the same when I set up the comparison. Anyway thank you very much!

Truth be told I had gotten into monkeying with this and the z-index for the flash <div> because while the 'transparent' param for flash galleries keeps the drop down menu on top, I found I needed to push the flash <div> down (in z-index) compared to my menu to maintain access to that (menu drop downs).

Thanks again!

P.S. While I found a lot of discussion here on the flash param for drop downs (and a knowledge base entry, http://www.simpleviewer.net/simpleviewe … ml#embed_5 ) maybe the general support site should have an entry for dealing with menu drop downs (re: z-indexing) for the mobile gallery as well.

Re: mobile thumbs inactive with linked css

I'm glad that solved the problem.

maybe the general support site should have an entry for dealing with menu drop downs (re: z-indexing) for the mobile gallery as well

Thank you for the suggestion.

Steven Speirs
SimpleViewer Support Team.