Topic: Warning: call_user_func_array()

Hi
I have tried too get simpleViewer run on my wp-blog(ver. 3.3.1) but it will not and i got some fault text. I whant this to run because i got the pro version also.

The fault text:
Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'suffusion_options_init_fn' was given in ......../wp-includes/plugin.php on line 405

Warning: call_user_func_array() [function.call-user-func-array]: First argument is expected to be a valid callback, 'suffusion_admin_init' was given in ........./wp-includes/plugin.php on line 405

Can somebody explaine whats wrong.

Best regards PES

Re: Warning: call_user_func_array()

The 'wp-includes/plugin.php' file is not part of WP-SimpleViewer and the warnings you posted refer to Suffusion which is likely to be the theme you are currently using.
At what point do you see the messages? Is it when activating WP-SimpleViewer? Is it when clicking a WP-SimpleViewer button within the Dashboard?
Try temporarily reverting to the default WordPress theme to see if there is perhaps an incompatibility between Suffusion and WP-SimpleViewer.

Steven Speirs
SimpleViewer Support Team.

Re: Warning: call_user_func_array()

Hi
Thanks for the answer, it seems to be the theme that's the problem.
Thanks

Re: Warning: call_user_func_array()

I have just installed and activated the Suffusion theme (v3.9.6) in a WordPress v3.3.1 installation.
My existing WP-SimpleViewer galleries continue to work OK and I am also able to successfully create new WP-SimpleViewer galleries.
It looks like the Suffusion theme is compatible with WP-SimpleViewer.
Make sure that your theme is up-to-date. If it already is, then try deactivating it, deleting it, re-installing and reactivating it.

Steven Speirs
SimpleViewer Support Team.