Topic: Flash and CSS not playing nice

I have a Simpleviewer gallery online.
It's working just fine. It's in its own div and behaving.

I have a CSS navigation menu just to the left of the movie. This menu has drop-down sub-menus that just happen to fall over the Gallery. I have done some reading from other posts in this forum, and came across the wmode, opaque line for the javascript. Even with this, the :hover states are still dropping out or showing intermittently.

Also, Safari and Firefox display this error, but in slightly different manors.
Any ideas as to how to get rid of the bad behavior?

Any help would be appreciated.

Re: Flash and CSS not playing nice

Have you tried adjusting the zindex for your div?

Re: Flash and CSS not playing nice

I set the zindex for the div to 1 for the Flash movie and the css roleovers still mis-behave. Was wondering if it has something to do with pseudo classes in the css.

Re: Flash and CSS not playing nice

have you tried v mode transparent?

got a url to look at?

Richard

in order to better assist you, please provide a url, relevant code and details about your problem.
Thanks!

Re: Flash and CSS not playing nice

Thanks - that seem to have helped. The roll-overs seem to behave better now. At this time I can't give out a URL as its a work in progress for someone else.

I seem to remember something about the area that a Flash animation occupies being sensitive to items being in front of it - something about frame rates. Different browsers treat it differently. A good example: look at Adobe's web site in Safari and Firefox and in both, roll over the top menu as there movie is playing. The rollover menu in Safari does not fair well.

Re: Flash and CSS not playing nice

Yes, transparent may make the flash animation less smooth and requires more of the users cpu, however, it solves problems like yours. I use it quite a bit. Always a trade off smile

Richard

in order to better assist you, please provide a url, relevant code and details about your problem.
Thanks!

Re: Flash and CSS not playing nice

Hi guys,
I have a related issue, posted on another thread. Any ideas? Any info, appreciated.

http://www.airtightinteractive.com/foru … down+menus