Topic: Cant solve the "Gallery XML Not Found"-error

Iam looking into if I can buy the Simpleviewer and implement with my site. So now I am testing it out. I want to embed it into my websitelayout but always get the "Gallery XML Not Found"-error. This is how it is setup now:

http://www.mjacobsson.se/tmp/sv/ - here is my SimpleViewer-files located. They are generated from SvBuilder-software.

http://www.mjacobsson.se/photos/templat … plate.html - this is the file I want want the embeded gallery to be seen from. My mainsite is built with PixelPost but I want to complement with SimpleViewer also. When everything is working the file above is accesed through PixelPost with "http://www.mjacobsson.se/photos/index.php?x=sv" (irrelevant for now I think).

This is how my embedcode looks like (in sv_template.html):

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.mjacobsson.se/tmp/sv/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.mjacobsson.se/tmp/sv/";
flashvars.galleryURL = "http://www.mjacobsson.se/tmp/sv/gallery.xml";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Both URLs at baseURL and galleryURL correct and the file (gallery.xml is there), still no luck.

Anyone?

Last edited by recman (2012-02-02 14:08:42)

Re: Cant solve the "Gallery XML Not Found"-error

You need to include the flashvars as a parameter in the embedding code.
Please see here for details: http://simpleviewer.net/simpleviewer/su … tml#params
Change:

simpleviewer.load("sv-container", "100%", "100%", "222222", true);

... to:

simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
Steven Speirs
SimpleViewer Support Team.

Re: Cant solve the "Gallery XML Not Found"-error

Steven Speirs wrote:

You need to include the flashvars as a parameter in the embedding code.
Please see here for details: http://simpleviewer.net/simpleviewer/su … tml#params
Change:

simpleviewer.load("sv-container", "100%", "100%", "222222", true);

... to:

simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);

Thanks a lot Steven, that seems to make the magic happen wink Cheers!