Topic: Problems with elastic gallery

Goodmorning!

It's the second time I create an Autoviewer gallery for an elastic website.
The first time I had precious help from this forum in solving my issue, so I want to try again smile

This is the gallery:
http://imageshack.us/photo/my-images/82 … 14320.png/
I've validated CSS and HTML and everything is ok. I've written everything to make it elastic, using only percentages for width and height. Everything in the website works in right percentages except for the  gallery. I really can't understand why the gallery looks so small, even if width and height are set to 100%.
For this gallery I've just copied the code from the first gallery I'd made and that worked: http://www.caroprocione.com/stellastell … allery.htm As you can see, that gallery is working so I think that code was right. So why now in this gallery is not working?

And the most absurd thing is this: the first time I've uploaded it on my server the gallery at least appeared (little, but it appeared), now it appears only offline on my computer (the screenshoot I've showed is local). As you can see, the gallery doesn't not show online: http://www.caroprocione.com/DOWNLOAD/Re … rtez-g.htm

I really can't understand why! Can you please help me? sad

Re: Problems with elastic gallery

Your gallery is not displayed because the 'swfobject.js' file (the JavaScript file which handles the embedding, cannot be found).
Your 's-diego-cortez-g.htm' page contains the line:

<script type="text/javascript" src="swfobject.js"></script>

... so the file should be located here: http://www.caroprocione.com/DOWNLOAD/Re … fobject.js
... but going directly to this location in a browser results in an error 404 (file not found).
Make sure you have uploaded the 'swfobject.js' file to your 'Relife' directory.

With regard to the resizing issue, it looks like you might be referring to the entire content on the page, not just the gallery.
Your 'style.css' page has set the 'width' of the 'container' <div> to 60%. Try increasing this to 100% for the 'conatiner' <div> to fill the entire width of the browser window.

Steven Speirs
SimpleViewer Support Team.

Re: Problems with elastic gallery

Oh, the first problem so dumb...... Thank you! I'm embarassed...
But I think the second problem won't be solved so easily...
The width for the div "container" MUST be 60% because it contains all data and must take only 60% center part of the page.
Anyway, I've tried to change its width with 100% and this is what it came out... http://img580.imageshack.us/img580/6828 … a22365.png Nothing changes and the look of the page is not the same...
I've created two classes to define the style of the gallery:

#contenutigallery { margin-top: 1em;
        margin-bottom: 1em;
    padding-left: 2em;
    padding-right: 1em;
    padding-top: 0.3em; 
    padding-bottom: 0.5em; 
    background: #000;
    height:100%;}
#flashcontent {
    height: 100%;
    width: 100%;
    overflow:auto;
    margin: 0; }

but they seem to be useless... I've tried to change widht and height with other percentages or with auto but nothing changes... I really do not know what else to do... This gallery does not behave as a normal object...

This is how it looks right now (I've separated the two div, the one with the gallery title and the gallery itself)
http://www.caroprocione.com/DOWNLOAD/Re … rtez-g.htm

Re: Problems with elastic gallery

The gallery seems to fit the area beneath 'Sfilata La Spiga Modamare' well and resizes with the browser window.

I really can't understand why the gallery looks so small, even if width and height are set to 100%.

If the 'flashcontent' <div>'s width is set to 100%, then the gallery will be displayed in a container that is 100% of the width of its parent container. The parent container (the 'container' <div>) has a width of 60% (of the total browser window width) so the gallery has a width of 100% x 60% x total width = 60% of total width and this is, indeed, the width of the gallery (not counting your padding).
For the height of the gallery, the 'flashcontent' <div> has been given a height of 100%.
However, it looks like the parent container of the gallery ('container') as well as the 'body' and 'html' elements have not been given specific heights via CSS.
Please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … ml#embed_7
The FAQ refers to SimpleViewer but relates to other viewers also.

Steven Speirs
SimpleViewer Support Team.