Topic: SimpleViewer 2.2.0 and Wordpress 3.3.1 compatibility issues

Hi,

I am a Multimedia Designer/Developer interested in using the latest version of SimpleViewer Pro on my client's website. I have successfully done this in the past using older versions of Wordpress and the WP-SimpleViewer plugin. I decided to try the latest free version to make sure it all works correctly with the latest version of Wordpress, but I have come across a few problems.

I have debug mode enabled in Wordpress and after I activated the plugin, this error message was repeated 4 times:
Notice: has_cap was called with an argument that is deprecated since version 2.0! Usage of user levels by plugins and themes is deprecated. Use roles and capabilities instead. in /home/4-web/46/47/newworldcaravans.com.au/public/www/wp-includes/functions.php on line 3551. I found out that this was related to the add_menus() function, but it didn't really help me solve the problem despite trying a number of different things to fix it.

Another major problem is that I can't see the 'eye' icon or 'Add SimpleViewer gallery' button anywhere when editing posts or pages. Both problems lead me to believe that there might be some compatibility issues with SimpleViewer 2.2.0 and Wordpress 3.3.1. Are there any known compatibility issues that might be the cause?

If anyone could give me some pointers as to what might be causing these problems or has a solution, it would be much appreciated. Also let me know if you need any more details in order to do this.

Thank you in advance.

Re: SimpleViewer 2.2.0 and Wordpress 3.3.1 compatibility issues

I just realised that someone posted a similar question as I was writing mine. The same thing happened with the 'eye' icon, where it only shows up in visual mode (when editing a post or page).

I will see how I go from here and keep an eye out for any other issues.

Re: SimpleViewer 2.2.0 and Wordpress 3.3.1 compatibility issues

Here is the forum thread to which medusa_g is referring: http://www.simpleviewer.net/forum/viewt … p?id=15403
I have now logged a bug report regarding the 'Add SimpleViewer Gallery' text button not showing up when the post's method of entry is 'HTML' rather than 'Visual'.

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer 2.2.0 and Wordpress 3.3.1 compatibility issues

Thanks for that Steve,

Along with the error message I mentioned above, I am also getting this message 'Notice: wp_specialchars is deprecated since version 2.8! Use esc_html() instead. in /home/4-web/46/47/newworldcaravans.com.au/public/www/wp-includes/functions.php on line 3467
Add SimpleViewer Gallery' when using the media uploader (with debug mode set to true).

Other than that, things seem to be running smoothly. I was able to add galleries to my posts (in visual mode) and they seem to functioning correctly.

I was wondering, what are these error messages all about and what effect do they have on the added galleries, if any? Also, I still intend to upgrade to Simpleviewer Pro, but with customisation can I be sure it will appear and function correctly?

Re: SimpleViewer 2.2.0 and Wordpress 3.3.1 compatibility issues

I was wondering, what are these error messages all about and what effect do they have on the added galleries, if any?

Thank you for posting the error messages.
Both error messages you posted are due to the use of deprecated code. However, they do not prevent a gallery from successfully being created. Nonetheless, I will notify the developers.

Also, I still intend to upgrade to Simpleviewer Pro, but with customisation can I be sure it will appear and function correctly?

I have had no trouble creating SimpleViewer galleries with the current version of WP-SimpleViewer and the code, though generating error messages in debug mode, should not cause any operational problems.
However, if you are looking for an alternative solution to WP-SimpleViewer, you could create a gallery with svBuilder/svBuilder-Pro, upload the entire gallery folder (not just the contents) to your web server and embed it in a post using one of the 2 methods documented here: http://simpleviewer.net/simpleviewer/su … l#external

Steven Speirs
SimpleViewer Support Team.

Re: SimpleViewer 2.2.0 and Wordpress 3.3.1 compatibility issues

Thanks for your reply. The error messages don't seem to be resulting in any functionality or display problems as far as I can tell.

I purchased the pro version regardless and am looking forward to 'pulling it apart' and applying customisations. I'll report any other issues if I come across them.

Options like svBuilder would be out of the questions as I would like my client to be able to create new galleries via Wordpress (without HTML or FTP uploads). SimpleViewer would be easy enough for them to use and update. The fact that it works with Wordpress's media uploader makes it even better, as I previously had to use a workaround to do this.