Topic: Don`t get it to work..

Hi!

I`ve read a lot of posts to find my solution but i dont..

I`m trying to make a gallery to my website; http://onskebakeren.no/side5.html

I have this html code; </HEAD>
<BODY style="MARGIN: 0px;BACKGROUND-COLOR: #ec008c">
<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://www.onskebakeren.no/images/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://www.onskebakeren.no/images/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", false, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED --><P>&nbsp;</P></BODY><P>&nbsp;</P></BODY>

Nothing happens on my site so i have probably done something veeery wrong. Im new to html and web-creating.. Im using one.com as web-server.

Any idea!?

Re: Don`t get it to work..

There are several problems with your page:

(1) Your page should use a Doctype Declaration.
Please see this page for details: http://www.w3.org/QA/2002/04/valid-dtd-list.html
Looking at your page, the following code (which should be placed at the very beginning of the page before the opening <html> tag) might be the most appropriate:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
   "http://www.w3.org/TR/html4/loose.dtd">

(2) Your page should have a closing </html> at the very end of the page after the closing </body> tag
You can validate your page with the W3C Validation Service to check for further HTML errors and fix any errors reported.

(3) The 'simpleviewer.js' file is not found at the specified location: http://www.onskebakeren.no/images/svcor … eviewer.js
Make sure that you have uploaded the 'svcore' to the correct location.

(4) You page is hosted at onskebakeren.no/side5.html but the references within the embedding code are to www.onskebakeren.no. www.onskebakeren.no is a subdomain of onskebakeren.no. Make sure that the references match (or use relative URLs within your embedding code).

Steven Speirs
SimpleViewer Support Team.

Re: Don`t get it to work..

Thank you! Usefull.. I think i have solved those four issues now. Now i get the message " Gallery xml not found". If you could help further i would really appreciate it!

What to do?!

Vegard

Re: Don`t get it to work..

Currently, your gallery uses the gollowing line of code:

flashvars.baseURL = "http://onskebakeren.no/SimpleViewer/svcore/js/simpleviewer.js";

The baseURL should point to the gallery folder (rather than to a file within it).
Use the following instead:

flashvars.baseURL = "http://onskebakeren.no/SimpleViewer/";

Please see the Flashvar Options section of the SimpleViewer-Pro Config Options page for a description of the baseURL option.

Steven Speirs
SimpleViewer Support Team.

Re: Don`t get it to work..

And there it is, awesome! A couple of things though.. How can i get the layout i chose when i made the gallery? And why is the background dark grey and not pink as i chose..?

Thank you for all help, amazing customer service!

Vegard

Re: Don`t get it to work..

Your gallery uses the following embedding code:

simpleviewer.load("sv-container", "100%", "100%", "222222", false, flashvars);

The '222222' entry is the backgroundColor Embed Code Parameter which you can change to 'ec008c' (pink) or 'transparent' (as you have set the background color of your page to #ec008c via CSS).

The 'false' entry is the useFlash Embed Code Parameter. Change this to 'true' and you should see the layout you expect.
Setting this parameter to 'false' forces the gallery to be displayed by the Mobile Player regardless of whether the user's browser is Flash-enabled or not.
Please see these FAQs for details:
http://simpleviewer.net/simpleviewer/su … trouble_14
http://simpleviewer.net/simpleviewer/su … l#mobile_1

Steven Speirs
SimpleViewer Support Team.