Topic: Problems with Internet Explorer and Firefox

Hello,

I have problems with viewing my gallery in Internet Explorer and Firefox.
I have been trying to find out for days and nights now...

On Mac, it's working with Safari, but not with Firefox.
On PC, it's working with Firefox, but not with Internet Explorer

This first page works well :
http://frederik.deze.free.fr/forceevent/darak.html

This next one doesn't work well :
http://frederik.deze.free.fr/forceevent/boutique.html

Can somebody have a look ?
Thanks.

Re: Problems with Internet Explorer and Firefox

On the page http://frederik.deze.free.fr/forceevent/boutique.html the embedding code uses the following line:

<script type="text/javascript" src="svcore\js\simpleviewer.js"></script>

Change the backslahses to slashes:

<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>

Also, your HTML document does not use a Doctype Declaration. Please see here for details: http://www.w3.org/QA/2002/04/valid-dtd-list.html

Steven Speirs
SimpleViewer Support Team.

Re: Problems with Internet Explorer and Firefox

Thank You so much Steven ! You saved my night. Now I can go to sleep with confidence cool
This is just fabulous how You just helped.

I changed the backslash for slash, and it works perfectly as supposed to do.
But my mac doesn't even have the blackslash  hmm so I don't know how it came to be so.

I'll watch this out next time. It's a small mistake but bringing a lot of trouble.

Your simple little viewer finaly works great  lol

Re: Problems with Internet Explorer and Firefox

I am having problems along the same lines. In Safari, we're pretty much prefect (except padding at the bottom). But in Safari, it's just not even showing. I love the look so I don't want to lose it without a fight. Any help would be great.
Thanks

http://www.jordanphilbrook.com/design.html

Re: Problems with Internet Explorer and Firefox

@JordanPhi

Try moving the following code on your page from the <head> section to below the 'flashContent' <div> in the <body> section:

<script type="text/javascript">
    var flashvars = {};
    flashvars.galleryURL = "gallery.xml";
    var params = {};            
    params.allowfullscreen = true;
    params.allowscriptaccess = "always";
    params.bgcolor = "b5d9f1";
    swfobject.embedSWF("js/simpleviewer.swf", "flashContent", "100%", "100%", "9.0.124", false, flashvars, params);
</script>
Steven Speirs
SimpleViewer Support Team.

Re: Problems with Internet Explorer and Firefox

Hello Steven!

I have problems with viewing my gallery in Internet Explorer...

It's working pretty well with Google Chrome, but not with Internet Explorer

http://www.angelicabombarda.com.br/marcosdigital/01

Can you please take a look?

Thanks!

Re: Problems with Internet Explorer and Firefox

@marcosdigital

Your gallery looks similar in Firefox 11 and IE9 on my computer.
If you are seeing a grid of thumbnails rather than the layout you specified, then please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … trouble_14

If this is not the problem you are experiencing, then please explain in greater detail what you are seeing and what you expect to see. Thank you.

Steven Speirs
SimpleViewer Support Team.

Re: Problems with Internet Explorer and Firefox

Steven, the problem seems to be the flash version! Thanks a lot!


Steven Speirs wrote:

@marcosdigital

Your gallery looks similar in Firefox 11 and IE9 on my computer.
If you are seeing a grid of thumbnails rather than the layout you specified, then please see this FAQ for details: http://simpleviewer.net/simpleviewer/su … trouble_14

If this is not the problem you are experiencing, then please explain in greater detail what you are seeing and what you expect to see. Thank you.