Topic: PHP problem

When I try to build a gallery using the buildgallery.php it now comes up with an error message. It was working a couple of weeks ago, but now it doesn't. Does anyone know how to fix this?




Creating XML and thumbnails for SimpleViewer.
-------------------------------------------------

Sorting images by filename.
Sorting images in forward order.

- Created Image Entry for: IMG_6405s.jpg
- Created Image Entry for: IMG_6406s.jpg
- Created Image Entry for: IMG_6435 copys.jpg
- Created Image Entry for: IMG_6444sp.jpg
- Created Image Entry for: IMG_6449s.jpg
- Created Image Entry for: IMG_6466s.jpg
- Created Image Entry for: IMG_6467s.jpg
- Created Image Entry for: IMG_6472s.jpg
- Created Image Entry for: IMG_6477 copys.jpg
- Created Image Entry for: IMG_6490s.jpg
- Created Image Entry for: IMG_6493bs.jpg
- Created Image Entry for: IMG_6513s.jpg
- Created Image Entry for: IMG_6518s.jpg
- Created Image Entry for: IMG_6520s.jpg
- Created Image Entry for: IMG_6526s.jpg
- Created Image Entry for: IMG_6561s.jpg
- Created Image Entry for: IMG_6589s.jpg
- Created Image Entry for: IMG_6590.jpg
- Created Image Entry for: IMG_6666s.jpg
- Created Image Entry for: IMG_6686s.jpg

Warning: fopen(gallery.xml) [function.fopen]: failed to open stream: Permission denied in /home/heather8/public_html/teresarakesh/buildgallery.php on line 115

Cannot open XML document: gallery.xml

Warning: fclose(): supplied argument is not a valid stream resource in /home/heather8/public_html/teresarakesh/buildgallery.php on line 122