Topic: Persian / Farsi

When embedding the simple viewer, the captions in Persian are not displayed correctly. Is there, or will there, ever be a fix for this? Thanks in advance.

Re: Persian / Farsi

Please see this FAQ entitled 'Non-English characters are not showing in the captions. Why?' for details: http://simpleviewer.net/simpleviewer/su … #trouble_4

Steven Speirs
SimpleViewer Support Team.

Re: Persian / Farsi

Thank you so much for your quick reply Steven. Unfortunately, the problem isn't that I can't see the captions but that they are in an incorrect order.

For example:

با زنده یاد

becomes switched the opposite way. (You may not read persian but, if you test it out, you can see how the text becomes disordered).

This seems like a tough one but thought I'd ask anyway, thanks.

Last edited by maanijaani (2012-02-22 13:20:17)

Re: Persian / Farsi

It sounds strange that the caption is not displayed as it is entered in the gallery's XML file.
Would you be able to post a URL to a gallery which displays this behavior so that we can take a look? Thank you.

Steven Speirs
SimpleViewer Support Team.

Re: Persian / Farsi

Hi, Sorry about my late reply.

Here is the site, I have tried to show you how the original text should be as well. Many thanks!

http://www.maaniyousofi.com/persianviewer/index.html

Re: Persian / Farsi

Thank you for posting the URL to your gallery.
Your captions are displayed correctly in the Mobile Player (on mobile devices and in browsers which do not have Adobe Flash Player installed and enabled) but not in the Flash Player.
It may be the case that the SWF file would need to embed a different font in order for this to work.
I will contact the developers regarding this issue.

Steven Speirs
SimpleViewer Support Team.

Re: Persian / Farsi

Thanks for your swift reply. Good luck, I hope they rectify this problem.

Just an additional note, the font is reversed as early as when I input the text in SV builder. (I have also tried to copy and paste into the xml via notepad with the same results).

Re: Persian / Farsi

For additional information, if I copy the text from your 'gallery.xml' file and paste it into a caption field in svBuilder, the text is immediately reversed.
However, if I paste the text into Windows Notepad, it is rendered correctly.
Have you tried changing the Font and/or script in Notepad ('Format -> Font...')?

Steven Speirs
SimpleViewer Support Team.

Re: Persian / Farsi

I'm not sure if I have fully understood you.

For me, the text is rendered correctly in gallery.xml when viewed in notepad, i.e. it is the correct way round. However, despite this, the actual gallery (in flash) continues to display the text in the incorrect order.


I hope my previous comment about the svbuilder didn't confuse things as I was simply trying to highlight that the svbuilder might be part of the problem, but it now seems it is to do with flash itself. Thanks again, keep us posted on the develpers' reply  smile

Re: Persian / Farsi

OK, thank you for clarifying.
To summarize: the text looks OK in Notepad but when copied and pasted into a caption field in svBuilder, it is immediately reversed. It is also reversed when the gallery is viewed with the Flash Player but not when viewed with the Mobile Player (where it is displayed correctly).

Thanks again, keep us posted on the develpers' reply

I will do.

Steven Speirs
SimpleViewer Support Team.