Topic: Upgraded to 1.8, followed upgrade directions, still no go...

I am having a problem with my Simpleviewer galleries. I have flash 9 installed, but it still prompts me to get flash when I try to view the galleries.  I looked at the FAQs and upgraded my existing gallery by uploading the swfobject.js and the new index to the gallery folder, but it still prompts me to get flash every time.

The URL for the gallery in question is http://www.frame14.com/Wedding.Gallery/default.htm

Not sure if this matters, but I used Picasa to generate my galleries and they work when I preview them in Frontpage.

Any ideas what's going on? Thanks for your help.

Ty

Re: Upgraded to 1.8, followed upgrade directions, still no go...

Check the FAQ, Q1: http://www.airtightinteractive.com/simp … r/faq.html

Felix Turner
SimpleViewer Support Team.

Re: Upgraded to 1.8, followed upgrade directions, still no go...

Hey Felix, thanks for the reply. I was actually in the process of editing my first post when you answered, and as you'll see from the new one I did check out the FAQs and make the upgrades.

It is now working in IE but not in Firefox. I downloaded the flash player for Firefox, so I can't figure out why it won't work. Any ideas?

Re: Upgraded to 1.8, followed upgrade directions, still no go...

I am also having the same problem.  I have followed the instructions in the FAQ to upgrade existing galleries (uploaded the swfobject.js file and edited the index.html) - still getting the upgrade flash message in Firefox only.

However, when using Internet Explorer everything is working fine.

Any ideas of why this isn't working in Firefox?

Re: Upgraded to 1.8, followed upgrade directions, still no go...

Did you clear your cache in FF?

Felix Turner
SimpleViewer Support Team.

Re: Upgraded to 1.8, followed upgrade directions, still no go...

I posted this same problem on a Nikon users forum (they have a thread for Web design) and was given a solution that worked for me. Specifically:

Update the flash_detect.js file by opening it in a text editor and changing the line that states:

var latestFlashVersion = 8;

to:
var latestFlashVersion = 9;

Give that a try and let me know if it works. It solved the problem for me!

Re: Upgraded to 1.8, followed upgrade directions, still no go...

Yes!  That did it - thanks for your help!

Re: Upgraded to 1.8, followed upgrade directions, still no go...

Where is the flash_detec.js located?

Re: Upgraded to 1.8, followed upgrade directions, still no go...

jchaggar, that flash_detect.js should be swfobject.js in your package, i guess. to make more crossplatform google around 'latest swfobject', version 1.4.4, if not mistaken. and don't forget to set the required player inside the script

cheers