Topic: "XML not found" on iphone4

Appollogies if this has been settled before, I could not find it.

I have used the baseurl, and global svcore methods when embedding a gallery.

The gallery displays properly in ie, chrome, ff, desktop browsers, which indicates all paths seem correct.

Checked the site in a freind's iphone4 (I don't have one), and get the error there.

Reading here, that indicates a pathing issue, but I don't know how that can be, since the paths seem correct.

Please advise what I have set incorrectly, thank you.

URL with gallery: http://www.ridgestyle.com/trips/lost-bowl-2012-03-07/

Embedding code:

<script type="text/javascript" src="http://dl.dropbox.com/u/1868808/__WEB/__global/simpleviewer/svcore/js/simpleviewer.js">
</script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://dl.dropbox.com/u/1868808/__WEB/ridgestyle/galleries/2012-03-07/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "transparent", true, flashvars);
});
</script>
<div style="height: 650px">
<div id="sv-container"> </div>
</div>

One other minor question:
In a browser preview directly out of svBuilder, the background color for the fullscreen button is the same color as the main image border color; But, in the live gallery, the background is black instead?

Re: "XML not found" on iphone4

This may be due to cross domain issues.
Are you able to host the gallery files on your own web server (rather than on Dropbox)?
If not, then a workaround may be to embed your gallery using the following <iframe> rather than the embedding code you posted.

<iframe src="http://dl.dropbox.com/u/1868808/__WEB/ridgestyle/galleries/2012-03-07/index.html" width="100%" height="650" allowtransparency="true" frameborder="0" scrolling="no"></iframe>
Steven Speirs
SimpleViewer Support Team.

Re: "XML not found" on iphone4

Steven Speirs wrote:

This may be due to cross domain issues.
Are you able to host the gallery files on your own web server (rather than on Dropbox)?

Yes, I can host the content on the same domain. I am using dbox for convieneince.

I will make the change and try again. I am trying to avoid using iFrames if possible.

Any idea about the fullscreen button background color?

Thanks again.

One other minor question:
In a browser preview directly out of svBuilder, the background color for the fullscreen button is the same color as the main image border color; But, in the live gallery, the background is black instead?

Re: "XML not found" on iphone4

The background color for the Fullscreen Button (and all other Button Bar buttons) is set via the buttonBarBackColor option.
It should be consistent from the live preview window in svBuilder-Pro, through svBuilder-Pro opening the gallery in a browser to you uploading the gallery to your web server.
In svBulder-Pro, you can click the 'Refresh' button (on the 'Customize' tab) to update the live preview window.
Also, make sure that you clear your browser's cache after making any changes in order to see the changes.
If you have a gallery where the Fullscreen Button's background color is black, rather than the color you have chosen via the buttonBarBackColor option, please post the URL to the gallery so that we can take a look.

Steven Speirs
SimpleViewer Support Team.

Re: "XML not found" on iphone4

It works correctly; It was user error.

Thank-You.