Topic: add new photos- refresh- not visible

Hello.
First - great Job with this tiltviewer.
I like it very much.

I will share my small experience and ask a question.

I uploaded it on the web - it is working fine.
I put the gallery in new page, only for the gallery.

When I open the gallery, I can click "Full Screen" only in the begining, before starting to look at the photos.
After that no matter how much time I press "full screen" - it is not working.
I must close the page , enter the page again and to press "Full Screen" before look at the photos.

Anyway, this is small problem and may be the problem is in my pc ?

Thi biggest issue, for me is that I decided to upload more pics.
There was 40, no there are 48 pics.
I change the config in the index.html 8x5 -> 8x6.
I added img paths in gallery.xml
I tried locally on my pc and it is working wqith no problems, new photos were there and visible.

But when I uploaded everything on the web, it shows the same 8x5, with no new pics.
I deleted the old index.html and gallery.xml from the server and uploaded and new ones.

I tried to refersh the page several times with no success.
Can someone give me some advice, please ?


Thanks in advance,
Kalin

P.S. Hm, strange. I change to try with another ISP and the new photos were loaded.
So I presume it should be some issue with the flash cache ? Some advice how to solve it ?

Last edited by darkrose2000 (2012-03-29 12:39:22)

Re: add new photos- refresh- not visible

When I open the gallery, I can click "Full Screen" only in the begining, before starting to look at the photos.
After that no matter how much time I press "full screen" - it is not working.
I must close the page , enter the page again and to press "Full Screen" before look at the photos.

The right-click options seem to be functioning erratically in Firefox (though they seem to work fine in Safari, Chrome and IE9 on my PC). This may well be a bug in the current version of Adobe Flash Player as I do not recall seeing this behavior with previous version of Adobe Flash Player and TiltViewer has not changed recently. I will report this to the developers. Thank you for pointing it out.

I tried to refersh the page several times with no success.

Refreshing the page is not enough. You should clear your browser's cache before reloading the gallery.

Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

Steven Speirs wrote:

Refreshing the page is not enough. You should clear your browser's cache before reloading the gallery.

Thankyou very much for the info.

Have a nice day,
Kalin

Re: add new photos- refresh- not visible

Hello,
me too I have the same problem of refresh under IE. Its not possible to be automatique? because even the F5 its not enough. And for some people that watch my gallery, they dont want each time to erase all the cache of IE, or they dont know how to do it.
Besides, I have another problem, with firefox (but no pb of refresh under firefox). When I go on my page, firefox ask me a password, like if it was an ftp server. If I take off the gallery on my htlm, he didnt ask the password..
I have entered no password, so I just say cancel and than its working.
Is it normal? Is it possible to take off this question for a password?

thank you very much:)

Re: add new photos- refresh- not visible

@mepad

me too I have the same problem of refresh under IE. Its not possible to be automatique? because even the F5 its not enough. And for some people that watch my gallery, they dont want each time to erase all the cache of IE, or they dont know how to do it.

In order to avoid the gallery's XML file being cached, you could try defining your gallery's XML file with a unique identifier (e.g. the current time which will be different each time a user loads the page) using the xmlURL option in your gallery's embedding code.

flashvars.xmlURL="gallery.xml?nocache="+new Date().getTime();

Besides, I have another problem, with firefox (but no pb of refresh under firefox). When I go on my page, firefox ask me a password, like if it was an ftp server. If I take off the gallery on my htlm, he didnt ask the password..
I have entered no password, so I just say cancel and than its working.
Is it normal? Is it possible to take off this question for a password?

TiltViewer does not feature password protection functionality. Protecting directories with passwords is usually achieved via .htaccess files on your web server. Your web host should be able to help you figure out why your browser asks for a password and how to remove it.

Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

ok thank you.
For the first question, Im not very good into coding. I guess, its not an option to check?
So I add your code in my embed, like this:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "000000", true);
});
</script>
<div id="sv-container"></div>
flashvars.xmlURL="gallery.xml?nocache="+new Date().getTime();
<!-- END SIMPLEVIEWER EMBED -->

But that change nothing, IE still dont update... My code is correct or not?
Thank you:)

For the second question, ok I will ask my web host, its what a was thinking too big_smile

Re: add new photos- refresh- not visible

You have posted in the TiltViewer forum so the code I posted was for a TiltViewer gallery.
Looking at the code you have posted in your most recent post, you are using SimpleViewer.
Your embedding code should look like this:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars={};
flashvars.galleryURL="gallery.xml?nocache="+new Date().getTime();
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "000000", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

Edit:
The original code I posted was, indeed, for TiltViewer but was also for those using SWFObject v2.2 to embed the SWF file.
For those reading this post and using TiltViewer with SWFObjct v1.5 (which TiltViewer comes bundled with), please use the following line in your embedding code:

fo.addVariable("xmlURL", "gallery.xml?nocache="+new Date().getTime());
Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

ok, I have tested, but it still the same, it doesnt update on IE sad
And for the password, my web host tell me its not possible to take off password to acces to my ftp. Which i dont understand because its a web page, and not a ftp link:(

Re: add new photos- refresh- not visible

ok, I have tested, but it still the same, it doesnt update on IE

I have just tested it myself in IE9 and it works as expected.
I created two test galleries(Gallery #1 and Gallery #2), identical other than Gallery #2 having the 'nocache' code in the 'index.html' file.
I uploaded both galleries and viewed both in individual tabs in IE9.
I then modified and uploaded the XML file of both galleries and hit F5 in both open tabs.
Gallery #1 redisplayed the original layout whilst Gallery # displayed the new layout demonstrating that the browser did not cache the XML file.
Try again and if it still does not work for you, please post the URL to your gallery so that I can take a look.

And for the password, my web host tell me its not possible to take off password to acces to my ftp. Which i dont understand because its a web page, and not a ftp link:(

Please post the URL to your web page so that I can take a look. There must be a reason that your web page is asking for a password but I do not know at present what it might be.

Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

Sorry...In fact, even without your code, its working:)
I was doing only F5, that is not enought. But if I close all my IE windows, than its working, my gallery is update. Sorry for loosing your time its me who were wrong.

For the firefox problem.
Here is a link to my gallery:
http://www.vincefx.com/gallerie/ImagesA … Archi.html

I just have a new answer from my web host, which says its the software (simple viewer) who call the link ftp://ftp.vincefx.com instead of www.vincefx.com
I dont know why. Into the customization of simple viewer, i don't put any ftp link. Do you have any idea?
Thanks again for your help.

Re: add new photos- refresh- not visible

ok..for the second problem, it was me again the problem... Into the customize/watermark there was a link to my ftp, so I erase it and now its working in firefox:)

I have another question:)
For the caption, is it possible to write on two lines? For exemple, for my first picture, right now I have:

</font><font color="#CCCCCC">Projet: Bureaux et extension - Date: Novembre 2011 - Production: Sequabat - Réalistation complète de l'image.</font> </p> <font color="#0066FF"><a href="http://www.vincefx.com">www.vincefx.com </a><font color="#CCCCCC"> vincefx@free.fr tel:06.98.72.06.93

but i would like one line:

</font><font color="#CCCCCC">Projet: Bureaux et extension - Date: Novembre 2011 - Production: Sequabat - Réalistation complète de l'image.</font> 

and on the second line:

<font color="#0066FF"><a href="http://www.vincefx.com">www.vincefx.com </a><font color="#CCCCCC"> vincefx@free.fr tel:06.98.72.06.93

I thought if i put </p> between it was working, but apparently no.
I have done a mistake again??

Re: add new photos- refresh- not visible

You can spit a caption into multiple lines by using an HTML line break <br> as in the example in this FAQ:
How do I add HTML formatting to my captions?

Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

ok thank you its working, you are perfect:)

Re: add new photos- refresh- not visible

Hello,
Since last summer, I haven't touch my gallerie.
But today I tried to update it and I still have my problem on IE9.  My gallery dont update. I have already restarted my computer, closed IE etc...
I have add the line     fo.addVariable("xmlDataPath", "gallery.xml?nocache="+new Date().getTime());
That change nothing... I dont understand.
On simple viewer i have put the option image preloading:page
The same for the thumbnail.
On firefox there is no problem, but on IE, (except if I delete manually my cache) Im not able to update my gallery..
Do you have any idea?

http://www.vincefx.com/gallerie/ImagesA … Archi.html

Thanks for your help...

Re: add new photos- refresh- not visible

On firefox there is no problem, but on IE, (except if I delete manually my cache) Im not able to update my gallery..
Do you have any idea?

It sounds like there is actually no problem with the gallery itself but that your IE browser is hanging onto and using older versions of your gallery files.

Please see this FAQ:
When I update my images, the new images do not show up in SimpleViewer. Why?
The FAQ refers to SimpleViewer but the principle is the same for TiltViewer.

I have add the line     fo.addVariable("xmlDataPath", "gallery.xml?nocache="+new Date().getTime());
That change nothing... I dont understand.

Adding that line to your gallery's embedding code should prevent the browser from caching your gallery's XML file by defining it with a unique query string identifier (e.g. the current time which will be different each time a user loads the page).

Unfortunately, the link you provided leads to an error 404 (file not found) page so I am unable to see your gallery in action.

Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

oups sorry. Its because I have add a "02" on my link so like this it was update.
http://www.vincefx.com/gallerie/ImagesA … Archi.html

I have just test, to add my original link http://www.vincefx.com/gallerie/ImagesA … Archi.html and it still not update. but on the new "02" yes, its update.

For the FAQ, yes I know I can clear the cache manually of IE, but that mean, each of my friend, or visitor, from IE need to clear the cache manually?

maybe the fo.addVariable("xmlDataPath", "gallery.xml?nocache="+new Date().getTime());
Is at the wrong place on my html?

Thanks

Re: add new photos- refresh- not visible

For the FAQ, yes I know I can clear the cache manually of IE, but that mean, each of my friend, or visitor, from IE need to clear the cache manually?

This is just the way that browsers work. If visitors to your web site have previously viewed your gallery prior to changes being made, then, under normal circumstances, they may need to clear their browser's cache before reloading the gallery.

oups sorry. Its because I have add a "02" on my link so like this it was update.

Now that I can view your gallery, I see that it is a SimpleViewer gallery. (You have posted in the TiltViewer thread and the fo.addVariable code is for TiltViewer.)
Change your embedding code from:

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
    simpleviewer.ready(function () {
        simpleviewer.load('sv-container', '100%', '100%', '000000', true);
    });
    fo.addVariable("xmlDataPath", "gallery.xml?nocache="+new Date().getTime());
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

... to:

<!--START SIMPLEVIEWER EMBED -->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
    var flashvars={};
    flashvars.galleryURL="gallery.xml?nocache="+new Date().getTime();
    simpleviewer.ready(function () {
        simpleviewer.load('sv-container', '100%', '100%', '000000', true, flashvars);
    });
</script>
<div id="sv-container"></div>
<!--END SIMPLEVIEWER EMBED -->

This should prevent the need for clearing your browser's cache as the gallery's XML file will be fetched from the web server (rather than the browser's cache) each time the gallery is displayed.

Steven Speirs
SimpleViewer Support Team.

Re: add new photos- refresh- not visible

Quick question: where should the line...

fo.addVariable("xmlDataPath", "gallery.xml?nocache="+new Date().getTime());

go in the code relative to the line...

fo.addVariable("xmlURL", "gallery.xml");

At the moment I've got it directly after but I'm still getting problems with caching (in firefox)

Re: add new photos- refresh- not visible

@MattGinn

You should replace the following line in your gallery's embedding code:

fo.addVariable("xmlURL", "gallery.xml");

... with:

fo.addVariable("xmlURL", "gallery.xml?nocache="+new Date().getTime());

(The 'xmlDataPath' variable was used for SimpleViewer v1.9 but not TiltViewer.)

Steven Speirs
SimpleViewer Support Team.