Topic: Please need help embedding

Hi all,

I am having a hard time embeding SV-Pro into a new HTML page. I looked and found this code on the SV site to embed into an existing HTML page.

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
simpleviewer.ready(function () {
simpleviewer.load("simpleviewer.swf", "100%", "100%", "222222", true);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

After adding the code I am unable to viewer the test gallery in my web browser www.greggerardphoto.com/test

In the test folder I have;
gallery.xml
images
index.html
simpleviewer.js
simpleviewer.swf
swfobject.js
Thumbs

I know I am missing something but cannot figure out what it may be. I'm using SV-Pro v2.3.0 and an older svBuilder v2.0.3.
Any help would be greatly appreciated. Thanks.

Last edited by racerx (2012-03-30 20:36:26)

Re: Please need help embedding

Copy the entire 'svcore' folder (not just the contents) from the SimpleViewer-Pro download package into your 'test' folder and it should work fine. The 'svcore' folder should be kept intact and the files within it should not be renamed or moved.
When you unzip the SimpleViewer-Pro download package, the 'svcore' folder can be found here: simpleviewer_pro_230/web/svcore
You can then remove the 'simpleviewer.js', 'simpleviewer.swf' and 'swfobject.js' files from your 'test' folder (as they are included in the 'svcore' folder).

Steven Speirs
SimpleViewer Support Team.

Re: Please need help embedding

Hi,
Thanks for the reply. I put the svcore folder into the test folder and removed the two .js file and the swf file. Still no luck. I am sure it must be something small but i just can't see it. www.greggerardphoto.com/test

File list now is;
gallery.xml
images
index.html
svcore
thumbs

Thanks for any help.

Last edited by racerx (2012-03-30 20:50:38)

Re: Please need help embedding

Hi all,

I got the test running. I had some bad coding in the .html page. I changed that and all worked great.  big_smile 

Thanks again for the help.

Re: Please need help embedding

I'm glad you've got it working. Thank you for posting back to let us know.

Steven Speirs
SimpleViewer Support Team.