Topic: gallery style: at first, only thumbnails

Hi
I need some help: I don't understand how to obtain a gallery with this style:

at first gallery shows only thumbnails (i.e. 6 rows x 6 columns)
than, when I click on one thumbnails, image open and I can navigate throught images.

I found this kind of gallery in a wordpress page made by a user of this forum - if I can show the link to better understand what I'd like to do, this is:
http://anthony.pimodi.com/random-photos-gunung-ledang/

thankyou for you help.
best,
Lorenza

Re: gallery style: at first, only thumbnails

The gallery to which you refer uses the Mobile Player which is usually used to display the gallery on mobile devices and in browsers which do not have Adobe Flash Player installed and enabled.
You can force your gallery to use the Mobile Player by setting the useFlash Embed Code Parameter to 'false'.
The simpleviewer.load() line in your embedding code would look something like this:

simpleviewer.load("sv-container", "100%", "100%", "222222", false);

If using svBuilder-Pro to create your gallery, deselect the 'Use Flash' checkbox in the 'Customize -> Embed Options' section.
It is not possible to set the number of thumbnail rows or columns (or pages) when using the Mobile Player. This is determined by the size of the user's browser window.

Steven Speirs
SimpleViewer Support Team.

Re: gallery style: at first, only thumbnails

Thankyou for the instant replay.
I tried the solution you pointed out on my wordpress testing page: I've deselect the 'Use Flash' in the wp Edit SimpleViewer Galleries Page and I 've got the  Mobile Player gallery.
There is an option I can not use, and don't know why:
the gallery is Flickr based, and I usually give a max height (500) and max width (700) to guarantee the max quality resolution. 
I always put the imageScaleMode="SCALE" to ensure the respect of this limit.
Don't know why: on the browser maximum height/width are respected, while on mobile , iPad , this are not, and images are published bigger .
With this Mobile Player gallery , using mobile system, I have the problem of bigger dimension even on my Mac browser...!
Why this?
Can't find a solution on SimpleViewer-Pro Config Options.
nb: I am working with svBuilder-Pro and than I usually copy and than paste options from gallery.xml to wp Edit SimpleViewer Galleries Page, cause I'm not able to put a folder with the gallery and embed it in a wordpress page - I've tried many times but with no success - so, I'm working on wp simplewiever plugin and I hope I can fix this problem with config option in this plug page!

Thankyou for help.
bye
Lorenza

Re: gallery style: at first, only thumbnails

Don't know why: on the browser maximum height/width are respected, while on mobile , iPad , this are not, and images are published bigger .
With this Mobile Player gallery , using mobile system, I have the problem of bigger dimension even on my Mac browser...!
Why this?

When the gallery is displayed using the Mobile Player, the images are scaled up to fill the available image area. (The Mobile Player was designed with small-screen devices in mind.)
There are no image scaling options available for the Mobile Player.

I'm not able to put a folder with the gallery and embed it in a wordpress page

This can be achieved by the following:
(1) Create a gallery using svBuilder-Pro
(2) Upload your complete gallery folder (not just the contents) to your web server via FTP using a program such as Filezilla
(3) Embed the gallery using the baseURL method as described here, ensuring that, when you enter the embedding code into the body of your post, that the method of entry is 'HTML' rather than 'Visual'

Steven Speirs
SimpleViewer Support Team.

Re: gallery style: at first, only thumbnails

ok - that's make sense!
thankyou for all the infos.
Lorenza

Re: gallery style: at first, only thumbnails

Hi,
I've tried again and again: embedding a sv gallery with the baseURL method.
Now , Id' like to do it because in the mobile player config I can have those pro option like...setting a maximum width and avoid  having the simpleviewer.net link at the bottom of the gallery... so, ask you if you can check where I'm doing wrong:

1) I make the gallery with svBuilder Pro
2) I put the gallery in the server ; I don't care where I put... I choose to use the upload folder
nb: I'm using a local tesing server - I have the galleries folder (named sv-gallery) and inside it my new gallery I've pubblished (named mob01)
I decide to put it in the upload folder - this is the path:
http://localhost/TestingSite/wp-content/uploads/sv-gallery/mob01/
3) I don't move anything in my gallery folder - as it is I still have:
gallery.xml
images folder
index.html
svcore folder
thumbs
4) I publish a post and in html mode I simple paste the code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://localhost/TestingSite/wp-content/uploads/sv-gallery/mob01/svcore/js/simpleviewer.js"></script>
<script type="text/javascript">
var flashvars = {};
flashvars.baseURL = "http://localhost/TestingSite/wp-content/uploads/sv-gallery/mob01/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
});
</script>
<div id="sv-container"></div>
<!-- END SIMPLEVIEWER EMBED -->

then I publish the post - and I find it totaly dark... nothing at all

where ma I wrong?!

Thanks
Lorenza

Re: gallery style: at first, only thumbnails

If your gallery had been uploaded to a web server (and had been assigned a publicly accessible web address), then you could use the absolute URL for the baseURL, such as:

flashvars.baseURL="http://www.example.com/test/gallery/";

Being that this is not the case, try using a relative URL for the baseURL (and the path to the 'simpleviewer.js' file), such as:

flashvars.baseURL="test/gallery/";

Please bear in mind that the relative URL will be relative to the HTML page into which the gallery is being embedded.

Steven Speirs
SimpleViewer Support Team.

Re: gallery style: at first, only thumbnails

... Nothing change -  now, I've published the page and if youc an have a look, the gallery exist:
http://hi.hisegnoallestimenti.com/wp-co … ery/mob01/

but, if I publish the post with the code:

<!--START SIMPLEVIEWER EMBED.-->
<script type="text/javascript" src="http://hi.hisegnoallestimenti.com/wp-content/uploads/sv-gallery/mob01/svcore/js/simpleviewer.js"></script><script type="text/javascript">// <![CDATA[
var flashvars = {};
flashvars.baseURL = "http://hi.hisegnoallestimenti.com/wp-co … ery/mob01/";
simpleviewer.ready(function () {
simpleviewer.load("sv-container", "100%", "100%", "222222", true, flashvars);
});
// ]]></script>
<div id="sv-container"></div>

than nothin appears:

http://hi.hisegnoallestimenti.com/prova-mobile/


Lorenza

Re: gallery style: at first, only thumbnails

Your gallery uses SimpleViewer-Pro v2.1.3 (and your embedding code loads the Pro v2.1.3 'simpleviewer.js' file).
However, the gallery is embedded in a WordPress page which has WP-SimpleViewer v2.2.0 installed and activated and, therefore, the page is also loading the Standard v2.2.0 'simpleviewer.js' file.

Ensure that both your WP-SimpleViewer installation and your manually embedded galleries both use the same version of SimpleViewer (the same 'svcore' folder). Otherwise, deactivating WP-SimpleViewer should allow your manually embedded galleries to be displayed without any further work.

Steven Speirs
SimpleViewer Support Team.

Re: gallery style: at first, only thumbnails

ok - that's make sense - thank for all your check.
Lorenza