Topic: changeImageonHover and other pro options not working

I purchased Simpleviewer Pro and svmanager but cannot get the pro options to work. I am certain the svcore files were upgraded as per Upgrading to a Pro Viewer but none of these options are working.

The gallery.xml file shows that svmanager is setting the options but when I click View in svmanager nothing happens.  Specifically, I am trying to get the main image to change as you rollover the thumbnails.

Any ideas what is wrong? Thanks!

Re: changeImageonHover and other pro options not working

I am certain the svcore files were upgraded as per Upgrading to a Pro Viewer but none of these options are working.

You can check if you have successfully upgraded your svManager installation from SimpleViewer-Standard to SimpleViewer-Pro by checking to see if the SimpleViewer badge/link is present at the bottom-right corner of your galleries. It will be present in all SimpleViewer-Standard galleries but will not be present in SimpleViewer-Pro galleries.

when I click View in svmanager nothing happens

This sounds like a separate, unrelated issue. When you click 'View' the gallery should open (likely in a new tab or window).
Try clicking 'Update' to save any changes first before clicking 'View'.

Specifically, I am trying to get the main image to change as you rollover the thumbnails.

The setting you'll need to use to achieve this is changeImageOnHover="TRUE" (though it sounds like you have found this in the 'Pro -> Thumbnails' section).

If you continue to experience difficulties, you might like to post in the svManager forum where the author of the program would be able to help you further.

Steven Speirs
SimpleViewer Support Team.

Re: changeImageonHover and other pro options not working

Thanks for your reply. And it is clear that my galleries created with svmanager are Simpleviewer galleries rather than SimpleViewer Pro because the SimpleViewer badge/link still appears. I can't believe how poorly I wrote the "nothing happens" complaint when I click on View.  What I meant to say is that a gallery is displayed but none of the SimpleViewer Pro parameters take effect. I apologize for the time you spent trying to figure out what I meant. The fact that I see no SimpleViewer Pro features, such as the changeImageonHover I am trying to use, corroborates the above observation. These galleries are not Pro galleries even though I am running latest version of svmanager (1.8) and explicitly replaced the svcore folder and contents when I tried to upgrade to Pro.

Got it to work! Replaced the svcore folder in both the sv2master and the g1 gallery and bingo: images change on rollover!

Thanks for leading me to the solution!

Re: changeImageonHover and other pro options not working

Got it to work!

Excellent! Thank you for posting back to let me know.

Replaced the svcore folder in both the sv2master and the g1 gallery and bingo: images change on rollover!

The 'svcore' folder should be replaced in the 'sv2master' folder in order for all future galleries created with svManager to be SimpleViewer-Pro galleries. However, existing galleries, such as 'g1', will still need to be upgraded separately (as they were previously created when svManager had only the SimpleViewer-Standard 'svcore' folder in the 'sv2master' folder).

Steven Speirs
SimpleViewer Support Team.

Re: changeImageonHover and other pro options not working

Steven Speirs wrote:

Got it to work!

Excellent! Thank you for posting back to let me know.

Replaced the svcore folder in both the sv2master and the g1 gallery and bingo: images change on rollover!

The 'svcore' folder should be replaced in the 'sv2master' folder in order for all future galleries created with svManager to be SimpleViewer-Pro galleries. However, existing galleries, such as 'g1', will still need to be upgraded separately (as they were previously created when svManager had only the SimpleViewer-Standard 'svcore' folder in the 'sv2master' folder).


I have changeonHover working well now and would like to know how you deactivate if if you roll over an image you would like to stay on.  When I find the desired image I get further image changes as I try to roll out of the thumbnails.  Any way to 'lock in an image selected by the changeonHover method?  Thanks!

Re: changeImageonHover and other pro options not working

Any way to 'lock in an image selected by the changeonHover method?

No. There is no way to toggle the value of the changeImageOnHover option once a gallery has been loaded.

Steven Speirs
SimpleViewer Support Team.

Re: changeImageonHover and other pro options not working

Steven Speirs wrote:

Any way to 'lock in an image selected by the changeonHover method?

No. There is no way to toggle the value of the changeImageOnHover option once a gallery has been loaded.


It would seem that the changeImageonHover option has no use or value if you are unable to select an image and act on it when the option is enabled.  I think this can be easily corrected with a couple of lines of actionscript in the thumbnail button that senses rollover and switches the image unless a thumbnail has been clicked:

on(press){
   changeImageonHover = false;
}

and a new 'perimeter' button surrounding the thumbnail array to sense mouse movement outside the thumbnails and turn changeImageonHover back on if necessary:

on(rollover){
  changeImageonHover = true;
}

Now you can rollover the thumbnails until you see the image you want, click on the thumbnail to select it, and then move to the image to click it and link to your linkURL.

What do you think?

Re: changeImageonHover and other pro options not working

As this is essentially a feature request, please post it in this thread so that it is not overlooked. Thank you.

Steven Speirs
SimpleViewer Support Team.